aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/conf
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-05-09 22:48:03 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2011-05-09 18:59:00 +0200
commitba31e4eabd31af63eb0244096c8bcdcac185fac6 (patch)
tree767541ea30f41bac59766c56a3ef3793694332b9 /meta-oe/conf
parent11bd2d2c2685445cfb0e61d297e70a578f0fa9ab (diff)
downloadmeta-openembedded-contrib-ba31e4eabd31af63eb0244096c8bcdcac185fac6.tar.gz
conf/layer.conf: Use .= for BBPATH and += for BBFILES
Provide additional commentary that should help a bit more Signed-off-by: Khem Raj <raj.khem@gmail.com> Acked-by: Paul Menzel <paulepanter@users.sourceforge.net> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/conf')
-rw-r--r--meta-oe/conf/layer.conf21
1 files changed, 18 insertions, 3 deletions
diff --git a/meta-oe/conf/layer.conf b/meta-oe/conf/layer.conf
index 9fa60c1c49..267616b623 100644
--- a/meta-oe/conf/layer.conf
+++ b/meta-oe/conf/layer.conf
@@ -1,9 +1,24 @@
-# We have a conf and classes directory, prepend to BBPATH to prefer our versions
-BBPATH := "${LAYERDIR}:${BBPATH}"
+# It really depends on order of the layers appearing in BBLAYERS
+# variable in toplevel bblayers.conf file, where bitbake will search
+# for .inc files and others where bitbake uses BBPATH since it will
+# search the directories from first to last as specified in BBPATH
+# Therefore if you want a given layer to be considered high priority
+# for the .inc and .conf etc. then consider it adding at the beginning
+# of BBPATH. For bblayers bitbake will use BBFILES_PRIORITY to resolve
+# the recipe contention so the order of directories in BBFILES does
+# not matter.
+
+# We have a conf and classes directory, append to BBPATH
+BBPATH .= ":${LAYERDIR}"
# We have a recipes directory, add to BBFILES
-BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb ${LAYERDIR}/recipes-*/*/*.bbappend"
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb ${LAYERDIR}/recipes-*/*/*.bbappend"
BBFILE_COLLECTIONS += "openembedded-layer"
BBFILE_PATTERN_openembedded-layer := "^${LAYERDIR}/"
+
+# Define the priority for recipes (.bb files) from this layer,
+# choosing carefully how this layer interacts with all of the
+# other layers.
+
BBFILE_PRIORITY_openembedded-layer = "6"