aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorwangmy <wangmy@fujitsu.com>2021-08-20 14:09:36 +0800
committerKhem Raj <raj.khem@gmail.com>2021-08-23 22:00:39 -0700
commit8500bbbf2c426a42882a80f35d1649f686032417 (patch)
tree27f22cbff0ea29f6e4056f78cee34d7ad484878f /meta-networking
parent442d214975df2bd4b9c30a64d13d1dc2f128f9e2 (diff)
downloadmeta-openembedded-contrib-8500bbbf2c426a42882a80f35d1649f686032417.tar.gz
netplan: upgrade 0.102 -> 0.103
0001-Handle-enum-element-override.patch removed since it is included in 0.103 Add patch to fix bug for 32bit format string bug. Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-connectivity/netplan/netplan/0001-Handle-enum-element-override.patch34
-rw-r--r--meta-networking/recipes-connectivity/netplan/netplan/0001-parse-nm-fix-32bit-format-string.patch25
-rw-r--r--meta-networking/recipes-connectivity/netplan/netplan_0.103.bb (renamed from meta-networking/recipes-connectivity/netplan/netplan_0.102.bb)11
3 files changed, 30 insertions, 40 deletions
diff --git a/meta-networking/recipes-connectivity/netplan/netplan/0001-Handle-enum-element-override.patch b/meta-networking/recipes-connectivity/netplan/netplan/0001-Handle-enum-element-override.patch
deleted file mode 100644
index dfc6f90c4c..0000000000
--- a/meta-networking/recipes-connectivity/netplan/netplan/0001-Handle-enum-element-override.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From 6d284f1ff81494a5fca91a399b92b218ea1a9ea8 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Tue, 8 Jun 2021 08:53:30 -0700
-Subject: [PATCH] Handle enum element override
-
-NETPLAN_DEF_TYPE_VIRTUAL and NETPLAN_DEF_TYPE_BRIDGE point
-to same value in enum, however here they are assigned individually
-which results in overriding the initialization of the objects
-
-Fixes
-src/netplan.h:85:33: error: initializer overrides prior initialization of this subobject [-Werror,-Winitializer-overrides]
- [NETPLAN_DEF_TYPE_BRIDGE] = "bridges",
- ^~~~~~~~~
-Upstream-Status: Submitted [https://github.com/canonical/netplan/pull/213]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- src/netplan.h | 1 -
- 1 file changed, 1 deletion(-)
-
-diff --git a/src/netplan.h b/src/netplan.h
-index d2c538b..26574f8 100644
---- a/src/netplan.h
-+++ b/src/netplan.h
-@@ -81,7 +81,6 @@ static const char* const netplan_def_type_to_str[NETPLAN_DEF_TYPE_MAX_] = {
- [NETPLAN_DEF_TYPE_ETHERNET] = "ethernets",
- [NETPLAN_DEF_TYPE_WIFI] = "wifis",
- [NETPLAN_DEF_TYPE_MODEM] = "modems",
-- [NETPLAN_DEF_TYPE_VIRTUAL] = NULL,
- [NETPLAN_DEF_TYPE_BRIDGE] = "bridges",
- [NETPLAN_DEF_TYPE_BOND] = "bonds",
- [NETPLAN_DEF_TYPE_VLAN] = "vlans",
---
-2.32.0
-
diff --git a/meta-networking/recipes-connectivity/netplan/netplan/0001-parse-nm-fix-32bit-format-string.patch b/meta-networking/recipes-connectivity/netplan/netplan/0001-parse-nm-fix-32bit-format-string.patch
new file mode 100644
index 0000000000..72f04a15ad
--- /dev/null
+++ b/meta-networking/recipes-connectivity/netplan/netplan/0001-parse-nm-fix-32bit-format-string.patch
@@ -0,0 +1,25 @@
+From 2f0ff65eaa93f18d9edb5d03329b00d8e5e73869 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Lukas=20M=C3=A4rdian?= <lukas.maerdian@canonical.com>
+Date: Wed, 4 Aug 2021 15:55:00 +0200
+Subject: [PATCH] parse-nm: fix 32bit format string
+
+---
+ src/parse-nm.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/parse-nm.c b/src/parse-nm.c
+index 9b09e34..bf998b7 100644
+--- a/src/parse-nm.c
++++ b/src/parse-nm.c
+@@ -136,7 +136,7 @@ static void
+ handle_bridge_uint(GKeyFile* kf, const gchar* key, NetplanNetDefinition* nd, char** dataptr) {
+ if (g_key_file_get_uint64(kf, "bridge", key, NULL)) {
+ nd->custom_bridging = TRUE;
+- *dataptr = g_strdup_printf("%lu", g_key_file_get_uint64(kf, "bridge", key, NULL));
++ *dataptr = g_strdup_printf("%"G_GUINT64_FORMAT, g_key_file_get_uint64(kf, "bridge", key, NULL));
+ _kf_clear_key(kf, "bridge", key);
+ }
+ }
+--
+2.25.1
+
diff --git a/meta-networking/recipes-connectivity/netplan/netplan_0.102.bb b/meta-networking/recipes-connectivity/netplan/netplan_0.103.bb
index 6c624ce4e9..682a6b611d 100644
--- a/meta-networking/recipes-connectivity/netplan/netplan_0.102.bb
+++ b/meta-networking/recipes-connectivity/netplan/netplan_0.103.bb
@@ -11,13 +11,12 @@ LICENSE = "GPLv3"
LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
S = "${WORKDIR}/git"
-SRCREV = "62701436991e42606c4e9e8dbdcdc5067d64f69b"
-PV = "0.102+git${SRCPV}"
+SRCREV = "51c872d856db80281ea810ebc02e05c09d5310fa"
+PV = "0.103"
+
+SRC_URI = "git://github.com/CanonicalLtd/netplan.git;branch=main \
+ file://0001-parse-nm-fix-32bit-format-string.patch"
-SRC_URI = " \
- git://github.com/CanonicalLtd/netplan.git \
- file://0001-Handle-enum-element-override.patch \
-"
SRC_URI:append:libc-musl = " file://0001-don-t-fail-if-GLOB_BRACE-is-not-defined.patch"
DEPENDS = "glib-2.0 libyaml ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"