aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2020-12-31 17:03:31 +0800
committerKhem Raj <raj.khem@gmail.com>2021-01-05 09:16:25 -0800
commit752bb30c39c30411eee2364d045863a6c1569c62 (patch)
tree0c231d8fb1a948b3ecc710095e4e12e0ffb68639 /meta-networking
parent5816f414affba9557fd94475fdb4aeb5715ef72f (diff)
downloadmeta-openembedded-contrib-752bb30c39c30411eee2364d045863a6c1569c62.tar.gz
ebtables: do not install /etc/ethertypes
Refer to Debian, patch the Makefile to prevent /etc/ethertypes installation instead of removing it in do_install_append. Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-filter/ebtables/ebtables-2.0.11/0001-Makefile.am-do-not-install-etc-ethertypes.patch34
-rw-r--r--meta-networking/recipes-filter/ebtables/ebtables_2.0.11.bb4
2 files changed, 35 insertions, 3 deletions
diff --git a/meta-networking/recipes-filter/ebtables/ebtables-2.0.11/0001-Makefile.am-do-not-install-etc-ethertypes.patch b/meta-networking/recipes-filter/ebtables/ebtables-2.0.11/0001-Makefile.am-do-not-install-etc-ethertypes.patch
new file mode 100644
index 0000000000..f2dbb552ea
--- /dev/null
+++ b/meta-networking/recipes-filter/ebtables/ebtables-2.0.11/0001-Makefile.am-do-not-install-etc-ethertypes.patch
@@ -0,0 +1,34 @@
+From a822e8dbca017e426a4c1c3ca835d0d03cbb4a4d Mon Sep 17 00:00:00 2001
+From: Yi Zhao <yi.zhao@windriver.com>
+Date: Thu, 31 Dec 2020 16:09:56 +0800
+Subject: [PATCH] Makefile.am: do not install /etc/ethertypes
+
+The /etc/ethertypes is provided by netbase since 6.0[1].
+Do not instal the file in ebtables, otherwise there would be a conflict:
+Error: Transaction test error:
+ file /etc/ethertypes conflicts between attempted installs of netbase-1:6.2-r0.corei7_64 and ebtables-2.0.10+4-r4.corei7_64
+
+[1] https://salsa.debian.org/md/netbase/-/commit/316680c6a2c3641b6abc76b3eebf88781f609d35)
+
+Upstream-Status: Inappropriate [embedded specific]
+
+Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
+---
+ Makefile.am | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index b879941..2237002 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -26,7 +26,6 @@ AM_CFLAGS = ${regular_CFLAGS}
+
+ sbin_PROGRAMS = ebtables-legacy ebtablesd ebtablesu ebtables-legacy-restore
+ EXTRA_PROGRAMS = static examples/ulog/test_ulog
+-sysconf_DATA = ethertypes
+ sbin_SCRIPTS = ebtables-legacy-save
+ man8_MANS = ebtables-legacy.8
+ lib_LTLIBRARIES = libebtc.la
+--
+2.17.1
+
diff --git a/meta-networking/recipes-filter/ebtables/ebtables_2.0.11.bb b/meta-networking/recipes-filter/ebtables/ebtables_2.0.11.bb
index be21c372d9..c13ed7b3bf 100644
--- a/meta-networking/recipes-filter/ebtables/ebtables_2.0.11.bb
+++ b/meta-networking/recipes-filter/ebtables/ebtables_2.0.11.bb
@@ -12,6 +12,7 @@ RRECOMMENDS_${PN} += "kernel-module-ebtables \
"
SRC_URI = "http://ftp.netfilter.org/pub/ebtables/ebtables-${PV}.tar.gz \
+ file://0001-Makefile.am-do-not-install-etc-ethertypes.patch \
file://ebtables-legacy-save \
file://ebtables.common \
file://ebtables.service \
@@ -25,9 +26,6 @@ SRC_URI[sha256sum] = "b71f654784a726329f88b412ef7b96b4e5d786ed2bd28193ed7b4c0d67
inherit systemd autotools
do_install_append () {
- #This file has been provided by netbase
- rm -f ${D}${sysconfdir}/ethertypes
-
# Replace upstream ebtables-save perl script with Fedora bash based rewrite
# http://pkgs.fedoraproject.org/cgit/rpms/ebtables.git/tree/ebtables-save
rm -f ${D}${sbindir}/ebtables-legacy-save