aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorTony Battersby <tonyb@cybernetics.com>2021-07-27 09:37:34 -0400
committerKhem Raj <raj.khem@gmail.com>2021-07-29 10:35:38 -0700
commit5e042ac2079bffa3ae3d9839a50bf6a3d3f1930a (patch)
tree3d0cb94a51de7a51677c9bc60e1782f24e098843 /meta-networking
parent86be1d89174ecfa91e7f323d49a301f51db01501 (diff)
downloadmeta-openembedded-contrib-5e042ac2079bffa3ae3d9839a50bf6a3d3f1930a.tar.gz
net-snmp: fix QA Issue after LDFLAGS change
Adding -f*-prefix-map to LDFLAGS caused the following issue: QA Issue: netsnmp-agent.pc failed sanity test (tmpdir) Fix by filtering out -f*-prefix-map from *.pc files. [YOCTO #14481] Signed-off-by: Tony Battersby <tonyb@cybernetics.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-protocols/net-snmp/net-snmp_5.9.1.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-networking/recipes-protocols/net-snmp/net-snmp_5.9.1.bb b/meta-networking/recipes-protocols/net-snmp/net-snmp_5.9.1.bb
index ed7f8428b1..aa497c8947 100644
--- a/meta-networking/recipes-protocols/net-snmp/net-snmp_5.9.1.bb
+++ b/meta-networking/recipes-protocols/net-snmp/net-snmp_5.9.1.bb
@@ -132,6 +132,11 @@ do_install_append() {
-e 's@[^ ]*PKG_CONFIG_LIBDIR=[^ "]*@@g' \
-i ${D}${bindir}/net-snmp-config
+ sed -e 's@[^ ]*-ffile-prefix-map=[^ "]*@@g' \
+ -e 's@[^ ]*-fdebug-prefix-map=[^ "]*@@g' \
+ -e 's@[^ ]*-fmacro-prefix-map=[^ "]*@@g' \
+ -i ${D}${libdir}/pkgconfig/netsnmp*.pc
+
# ${STAGING_DIR_HOST} is empty for native builds, and the sed command below
# will result in errors if run for native.
if [ "${STAGING_DIR_HOST}" ]; then