aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2021-08-13 12:42:12 +0800
committerKhem Raj <raj.khem@gmail.com>2021-08-12 22:58:40 -0700
commit4940e9fb6ac84d964eabeab77a0e0b0bc97ded99 (patch)
tree858a9d5231e90bdc7a8757fa8e4667dbe8cddc06 /meta-networking
parent9a93c7666fcf8b22318e5e814a373245f3e20f1d (diff)
downloadmeta-openembedded-contrib-4940e9fb6ac84d964eabeab77a0e0b0bc97ded99.tar.gz
networkmanager: add PACKAGECONFIG for audit and selinux
Add them to PACKAGECONFIG if enable selinux distro feature. Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-connectivity/networkmanager/networkmanager_1.32.4.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/networkmanager/networkmanager_1.32.4.bb b/meta-networking/recipes-connectivity/networkmanager/networkmanager_1.32.4.bb
index 0ef525d31d..167d810226 100644
--- a/meta-networking/recipes-connectivity/networkmanager/networkmanager_1.32.4.bb
+++ b/meta-networking/recipes-connectivity/networkmanager/networkmanager_1.32.4.bb
@@ -59,6 +59,7 @@ PACKAGECONFIG ??= "nss ifupdown dnsmasq nmcli \
${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', bb.utils.contains('DISTRO_FEATURES', 'x11', 'consolekit', '', d), d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez5', '', d)} \
${@bb.utils.filter('DISTRO_FEATURES', 'wifi polkit', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'selinux', 'selinux audit', '', d)} \
"
inherit ${@bb.utils.contains('PACKAGECONFIG', 'nmcli', 'bash-completion', '', d)}
@@ -83,6 +84,8 @@ PACKAGECONFIG[qt4-x11-free] = "--enable-qt,--disable-qt,qt4-x11-free"
PACKAGECONFIG[cloud-setup] = "--with-nm-cloud-setup=yes,--with-nm-cloud-setup=no"
PACKAGECONFIG[nmcli] = "--with-nmcli=yes,--with-nmcli=no,readline"
PACKAGECONFIG[ovs] = "--enable-ovs,--disable-ovs,jansson"
+PACKAGECONFIG[audit] = "--with-libaudit,--without-libaudit,audit"
+PACKAGECONFIG[selinux] = "--with-selinux,--without-selinux,libselinux"
PACKAGES =+ " \
${PN}-nmcli ${PN}-nmcli-doc \