aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-01-29 16:41:55 -0800
committerKhem Raj <raj.khem@gmail.com>2023-01-29 21:09:39 -0800
commit426a1e4f8f2e3318b0518ffbb29d8caa769450e2 (patch)
tree5da25353d88af01c177a208375c96dd2784024cf /meta-networking
parent0d973d9470f0a5bd96e772d396131112656df2a5 (diff)
downloadmeta-openembedded-contrib-426a1e4f8f2e3318b0518ffbb29d8caa769450e2.tar.gz
dante: Add -P to preprocessor flags
configure uses AC_PREPROC_IFELSE to check for certain errors from getaddrinfo() it user search operation in a preprocessed file UNIQUEVALS=`sort $ERRVALFILE | uniq | wc -l | awk '{ print $1 }'` However, line numbers are generated into the preprocesser files and they get sorted higher than numbers gaierrval: # 130 "conftest.c" 3 4 -3 -P ensures that line numbers are not generated into preprocessed files, so these checks can succeed. Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-protocols/dante/dante_1.4.3.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-networking/recipes-protocols/dante/dante_1.4.3.bb b/meta-networking/recipes-protocols/dante/dante_1.4.3.bb
index 746c08be6e..4badff8bbd 100644
--- a/meta-networking/recipes-protocols/dante/dante_1.4.3.bb
+++ b/meta-networking/recipes-protocols/dante/dante_1.4.3.bb
@@ -25,6 +25,7 @@ EXTRA_OECONF += "--without-gssapi --sbindir=${bindir}"
DEPENDS += "flex-native bison-native libpam libtirpc"
inherit autotools-brokensep features_check
+CPPFLAGS += "-P"
CFLAGS += "-I${STAGING_INCDIR}/tirpc"
LIBS += "-ltirpc"