aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-09-01 13:06:45 -0700
committerKhem Raj <raj.khem@gmail.com>2022-09-01 13:09:22 -0700
commit26af1e567341502b51f4d762434eaedff8673d2e (patch)
tree85b5d4ed1faae91f41dd3ac7ada10c0d45f9c680 /meta-networking
parentd8c94d06cfaa98436344dfe80085d5d0f505873b (diff)
downloadmeta-openembedded-contrib-26af1e567341502b51f4d762434eaedff8673d2e.tar.gz
quagga: Fix AC_CHECK_LIB for libreadline
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-protocols/quagga/files/0001-configure-Check-for-readline-instead-of-main-in-libr.patch32
-rw-r--r--meta-networking/recipes-protocols/quagga/quagga_1.2.4.bb2
2 files changed, 34 insertions, 0 deletions
diff --git a/meta-networking/recipes-protocols/quagga/files/0001-configure-Check-for-readline-instead-of-main-in-libr.patch b/meta-networking/recipes-protocols/quagga/files/0001-configure-Check-for-readline-instead-of-main-in-libr.patch
new file mode 100644
index 0000000000..776c0958fa
--- /dev/null
+++ b/meta-networking/recipes-protocols/quagga/files/0001-configure-Check-for-readline-instead-of-main-in-libr.patch
@@ -0,0 +1,32 @@
+From 675b35b7ed416c837267e493b157167319e8f5fa Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Thu, 1 Sep 2022 11:01:53 -0700
+Subject: [PATCH] configure: Check for readline() instead of main() in
+ libreadline
+
+while checking for presense of libreadline, poke for a function which is
+provided by libreadline, main is not provided by it, so modern compiler
+toolchains may complain about it.
+
+Upstream-Status: Submitted [https://github.com/Quagga/quagga/pull/9]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index ed279f48..d444ab4a 100755
+--- a/configure.ac
++++ b/configure.ac
+@@ -754,7 +754,7 @@ dnl [TODO] on Linux, and in [TODO] on Solaris.
+ )]
+ )]
+ )
+- AC_CHECK_LIB(readline, main, LIBREADLINE="-lreadline $LIBREADLINE",,
++ AC_CHECK_LIB(readline, readline, LIBREADLINE="-lreadline $LIBREADLINE",,
+ "$LIBREADLINE")
+ if test $ac_cv_lib_readline_main = no; then
+ AC_MSG_ERROR([vtysh needs libreadline but was not found and usable on your system.])
+--
+2.37.3
+
diff --git a/meta-networking/recipes-protocols/quagga/quagga_1.2.4.bb b/meta-networking/recipes-protocols/quagga/quagga_1.2.4.bb
index 984264a30f..37cfc131c2 100644
--- a/meta-networking/recipes-protocols/quagga/quagga_1.2.4.bb
+++ b/meta-networking/recipes-protocols/quagga/quagga_1.2.4.bb
@@ -1,5 +1,7 @@
require quagga.inc
+SRC_URI += "file://0001-configure-Check-for-readline-instead-of-main-in-libr.patch"
+
SRC_URI[md5sum] = "eced21b054d71c9e1b7c6ac43286a166"
SRC_URI[sha256sum] = "e364c082c3309910e1eb7b068bf39ee298e2f2f3f31a6431a5c115193bd653d3"