aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorDaiane Angolini <daiane.angolini@foundries.io>2021-06-22 12:10:08 -0300
committerKhem Raj <raj.khem@gmail.com>2021-06-23 10:46:24 -0700
commit500ce4d46d8878a5dc43e932db6c133288584d19 (patch)
treee4dfcde4331bea8b3b5301e6ed551eac64d38b68 /meta-networking
parenta976968c10e9ba63abd899239501a73bbff6b253 (diff)
downloadmeta-openembedded-contrib-500ce4d46d8878a5dc43e932db6c133288584d19.tar.gz
wireguard-module: Stop overriding modules_install in the recipe
Configure the recipe to use the module_install function from the module source code and remove the overriden modules_install function from the recipe. Using the default modules_install (instead of the function defined in the recipe file) the module is signed when DISTRO_FEATURE contains modsign. Signed-off-by: Daiane Angolini <daiane.angolini@foundries.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-kernel/wireguard/wireguard-module_1.0.20210219.bb6
1 files changed, 1 insertions, 5 deletions
diff --git a/meta-networking/recipes-kernel/wireguard/wireguard-module_1.0.20210219.bb b/meta-networking/recipes-kernel/wireguard/wireguard-module_1.0.20210219.bb
index 0525b4135a..01e3b74c65 100644
--- a/meta-networking/recipes-kernel/wireguard/wireguard-module_1.0.20210219.bb
+++ b/meta-networking/recipes-kernel/wireguard/wireguard-module_1.0.20210219.bb
@@ -17,15 +17,11 @@ EXTRA_OEMAKE_append = " \
"
MAKE_TARGETS = "module"
+MODULES_INSTALL_TARGET = "module-install"
RRECOMMENDS_${PN} = "kernel-module-xt-hashlimit"
MODULE_NAME = "wireguard"
-module_do_install() {
- install -d ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/kernel/${MODULE_NAME}
- install -m 0644 ${MODULE_NAME}.ko \
- ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/kernel/${MODULE_NAME}/${MODULE_NAME}.ko
-}
# WireGuard has been merged into Linux kernel >= 5.6 and therefore this compatibility module is no longer required.
# OE-core post dunfell has moved to use kernel 5.8 which now means we cant build this module in world builds