aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2019-04-18 17:54:07 +0200
committerKhem Raj <raj.khem@gmail.com>2019-04-27 10:13:07 -0700
commitf066c44859e15296b7a1019f1badfdfff073eb39 (patch)
tree1a385a77e3ace2d032b0d161e3af1fbf1a3fc433 /meta-networking
parentd9b57a7244bda29127dd8fc94f55daa0d7d66dd7 (diff)
downloadmeta-openembedded-contrib-f066c44859e15296b7a1019f1badfdfff073eb39.tar.gz
samba: install bundled libs into seperate packages
Otherwise bundled libraries find their way into samba -> that causes several packages to rdepend on samba package -> samba package rdepends on samba-base (and others) installing daemons smbd & nmbd autostarted by default. This is unwanted / not necessary: * NetBIOS (nmbd) can cause a security problems * slow boot: times reported by systemd-analyse reduced from ~16s -> ~8s Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-connectivity/samba/samba_4.8.4.bb10
1 files changed, 10 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/samba/samba_4.8.4.bb b/meta-networking/recipes-connectivity/samba/samba_4.8.4.bb
index e86ed96a5d..aa80871315 100644
--- a/meta-networking/recipes-connectivity/samba/samba_4.8.4.bb
+++ b/meta-networking/recipes-connectivity/samba/samba_4.8.4.bb
@@ -107,6 +107,16 @@ SAMBA4_MODULES="${SAMBA4_IDMAP_MODULES},${SAMBA4_PDB_MODULES},${SAMBA4_AUTH_MODU
#
SAMBA4_LIBS="heimdal,cmocka,ldb,pyldb-util,NONE"
+# interim packages: As long as ldb/pyldb-util are in SAMBA4_LIBS we need to pack
+# bundled libraries in seperate packages. Otherwise they are auto-packed in
+# package 'samba' which RDEPENDS on lots of packages not wanted e.g autostarting
+# nmbd/smbd daemons
+# Once 'ldb,pyldb-util' are removed from SAMBA4_LIBS the bundled packages can
+# be removed again.
+PACKAGES =+ "${PN}-bundled-ldb ${PN}-bundled-pyldb-util"
+FILES_${PN}-bundled-ldb = "${libdir}/samba/libldb${SOLIBS}"
+FILES_${PN}-bundled-pyldb-util = "${libdir}/samba/libpyldb-util${SOLIBS}"
+
EXTRA_OECONF += "--enable-fhs \
--with-piddir=/run \
--with-sockets-dir=/run/samba \