aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2019-06-10 00:13:10 -0700
committerKhem Raj <raj.khem@gmail.com>2019-06-15 16:45:33 -0700
commit57929333d9492115f3dd006200d710634dc432aa (patch)
tree3d52b0c3fbd6dd760e6e35e63db4ce321dae9445 /meta-networking
parent3ae37ea26137b0f31d3f1e4b3e378130672b539a (diff)
downloadmeta-openembedded-contrib-57929333d9492115f3dd006200d710634dc432aa.tar.gz
kea: replace -Og with -O
With below logic in local.conf: MACHINE ??= "qemumips64" MULTILIB_GLOBAL_VARIANTS_append = " libn32" MULTILIBS ?= "multilib:lib32 multilib:libn32" DEFAULTTUNE_virtclass-multilib-lib32 ?= "mips" DEFAULTTUNE_virtclass-multilib-libn32 ?= "mips64-n32" require conf/multilib.conf DEBUG_BUILD = "1" $ bitbake lib32-kea [snip] {standard input}: Assembler messages: {standard input}:305030: Error: branch out of range {standard input}:305041: Error: branch out of range {standard input}:305432: Error: branch out of range {standard input}:305443: Error: branch out of range Makefile:707: recipe for target 'dhcp4_parser.lo' failed make[6]: *** [dhcp4_parser.lo] Error 1 [snip] When DEBUG_BUILD enabled, -Og pass to compiler, replace -Og with -O to fix the above compile error. Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-connectivity/kea/kea_1.5.0.bb10
1 files changed, 10 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/kea/kea_1.5.0.bb b/meta-networking/recipes-connectivity/kea/kea_1.5.0.bb
index 9210ac1bc1..fb166df607 100644
--- a/meta-networking/recipes-connectivity/kea/kea_1.5.0.bb
+++ b/meta-networking/recipes-connectivity/kea/kea_1.5.0.bb
@@ -23,6 +23,16 @@ inherit autotools systemd
SYSTEMD_SERVICE_${PN} = "kea-dhcp4.service kea-dhcp6.service kea-dhcp-ddns.service"
SYSTEMD_AUTO_ENABLE = "disable"
+DEBUG_OPTIMIZATION_remove_mips = " -Og"
+DEBUG_OPTIMIZATION_append_mips = " -O"
+BUILD_OPTIMIZATION_remove_mips = " -Og"
+BUILD_OPTIMIZATION_append_mips = " -O"
+
+DEBUG_OPTIMIZATION_remove_mipsel = " -Og"
+DEBUG_OPTIMIZATION_append_mipsel = " -O"
+BUILD_OPTIMIZATION_remove_mipsel = " -Og"
+BUILD_OPTIMIZATION_append_mipsel = " -O"
+
do_configure_prepend_class-target() {
mkdir -p ${B}/src/lib/log/compiler/
ln -sf ${STAGING_BINDIR_NATIVE}/kea-msg-compiler ${B}/src/lib/log/compiler/kea-msg-compiler