aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2020-11-05 17:30:13 +0800
committerKhem Raj <raj.khem@gmail.com>2020-11-09 20:49:52 -0800
commit1b37387c39d161145b36af4ee9f9194f64b93341 (patch)
tree6953bb08c71bb32cadcd0f23b504a473c1ec22ed /meta-networking
parentb7274c62b3f27179702b00f26c2fb93c2f7c3eb6 (diff)
downloadmeta-openembedded-contrib-1b37387c39d161145b36af4ee9f9194f64b93341.tar.gz
ndpi: add new recipe
nDPI is an open source LGPLv3 library for deep-packet inspection. Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/ntopng/files/0001-autogen.sh-not-generate-configure.patch33
-rw-r--r--meta-networking/recipes-support/ntopng/ndpi_3.4.bb26
2 files changed, 59 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/ntopng/files/0001-autogen.sh-not-generate-configure.patch b/meta-networking/recipes-support/ntopng/files/0001-autogen.sh-not-generate-configure.patch
new file mode 100644
index 0000000000..ffc6ec1efc
--- /dev/null
+++ b/meta-networking/recipes-support/ntopng/files/0001-autogen.sh-not-generate-configure.patch
@@ -0,0 +1,33 @@
+From d482bcc8fca90afc95ac3cbe848a3c9d7ad81ddc Mon Sep 17 00:00:00 2001
+From: Mingli Yu <mingli.yu@windriver.com>
+Date: Wed, 4 Nov 2020 23:37:44 -0800
+Subject: [PATCH] autogen.sh: not generate configure
+
+Only use autogen.sh to generate configure.ac.
+
+Upstream-Status: Inappropriate [embedded specific]
+
+Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
+---
+ autogen.sh | 8 --------
+ 1 file changed, 8 deletions(-)
+
+diff --git a/autogen.sh b/autogen.sh
+index df734ce9..d7bbf8cb 100755
+--- a/autogen.sh
++++ b/autogen.sh
+@@ -52,11 +52,3 @@ cat configure.seed | sed \
+ -e "s/@NDPI_VERSION_SHORT@/$NDPI_VERSION_SHORT/g" \
+ -e "s/@FUZZY@/$FUZZY/g" \
+ > configure.ac
+-
+-autoreconf -ivf
+-cat configure | sed "s/#define PACKAGE/#define NDPI_PACKAGE/g" | sed "s/#define VERSION/#define NDPI_VERSION/g" > configure.tmp
+-cat configure.tmp > configure
+-
+-chmod +x configure
+-./configure $@
+-
+--
+2.17.1
+
diff --git a/meta-networking/recipes-support/ntopng/ndpi_3.4.bb b/meta-networking/recipes-support/ntopng/ndpi_3.4.bb
new file mode 100644
index 0000000000..1e41537799
--- /dev/null
+++ b/meta-networking/recipes-support/ntopng/ndpi_3.4.bb
@@ -0,0 +1,26 @@
+SUMMARY = "A library for deep-packet inspection."
+DESCRIPTION = "nDPI is an open source LGPLv3 library for deep-packet \
+inspection. Based on OpenDPI it includes ntop extensions"
+
+SECTION = "libdevel"
+DEPENDS = "libpcap"
+RDEPENDS_${PN} += " libpcap"
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b52f2d57d10c4f7ee67a7eb9615d5d24"
+
+SRCREV = "64929a75e0a7a60d864bd25a9fd97fdf9ac892a2"
+SRC_URI = "git://github.com/ntop/nDPI.git;branch=3.4-stable \
+ file://0001-autogen.sh-not-generate-configure.patch \
+"
+
+S = "${WORKDIR}/git"
+
+inherit autotools-brokensep pkgconfig
+
+do_configure_prepend() {
+ ${S}/autogen.sh
+}
+
+EXTRA_OEMAKE = " \
+ libdir=${libdir} \
+"