aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2020-10-14 15:04:08 +0800
committerKhem Raj <raj.khem@gmail.com>2020-10-14 08:39:34 -0700
commit17bc2a137f1c249a167a478f596d61b5489e7fa4 (patch)
treeb93eeb9211745a2ae276f06ac138c1bf8d4c728f /meta-networking
parentbebdea8530652ff698885a3f55b0a650de319379 (diff)
downloadmeta-openembedded-contrib-17bc2a137f1c249a167a478f596d61b5489e7fa4.tar.gz
networkmanager: remove PACKAGECONFIG[dhclient]
The dhcp-client has been removed from oe-core and the current networkmanager does not support dhcpcd >= 9.0 (See bug report: https://gitlab.freedesktop.org/NetworkManager/NetworkManager/-/issues/410) Remove the PACKAGECONFIG[dhclient] and pass --with-dhclient/dhcpcd=no explicitly to EXTRA_OECONF. Otherwise it will search the host path when configure. Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-connectivity/networkmanager/networkmanager_1.22.14.bb8
1 files changed, 5 insertions, 3 deletions
diff --git a/meta-networking/recipes-connectivity/networkmanager/networkmanager_1.22.14.bb b/meta-networking/recipes-connectivity/networkmanager/networkmanager_1.22.14.bb
index ac2282ea1b..2613076a7e 100644
--- a/meta-networking/recipes-connectivity/networkmanager/networkmanager_1.22.14.bb
+++ b/meta-networking/recipes-connectivity/networkmanager/networkmanager_1.22.14.bb
@@ -45,6 +45,10 @@ EXTRA_OECONF = " \
--with-tests \
--with-nmtui=yes \
--with-udev-dir=${nonarch_base_libdir}/udev \
+ --with-dhclient=no \
+ --with-dhcpcd=no \
+ --with-dhcpcanon=no \
+ --with-netconfig=no \
"
# stolen from https://github.com/void-linux/void-packages/blob/master/srcpkgs/NetworkManager/template
@@ -58,7 +62,7 @@ do_compile_prepend() {
export GIR_EXTRA_LIBS_PATH="${B}/libnm/.libs:${B}/libnm-glib/.libs:${B}/libnm-util/.libs"
}
-PACKAGECONFIG ??= "nss ifupdown dhclient dnsmasq \
+PACKAGECONFIG ??= "nss ifupdown dnsmasq \
${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', bb.utils.contains('DISTRO_FEATURES', 'x11', 'consolekit', '', d), d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez5', '', d)} \
${@bb.utils.filter('DISTRO_FEATURES', 'wifi polkit', d)} \
@@ -73,8 +77,6 @@ PACKAGECONFIG[bluez5] = "--enable-bluez5-dun,--disable-bluez5-dun,bluez5"
PACKAGECONFIG[consolekit] = "--with-session-tracking=consolekit,,consolekit,consolekit"
PACKAGECONFIG[modemmanager] = "--with-modem-manager-1=yes,--with-modem-manager-1=no,modemmanager"
PACKAGECONFIG[ppp] = "--enable-ppp,--disable-ppp,ppp,ppp"
-# Use full featured dhcp client instead of internal one
-PACKAGECONFIG[dhclient] = "--with-dhclient=${base_sbindir}/dhclient,,,dhcpcd"
PACKAGECONFIG[dnsmasq] = "--with-dnsmasq=${bindir}/dnsmasq"
PACKAGECONFIG[nss] = "--with-crypto=nss,,nss"
PACKAGECONFIG[resolvconf] = "--with-resolvconf=${base_sbindir}/resolvconf,,,resolvconf"