aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-02-04 15:17:01 -0800
committerKhem Raj <raj.khem@gmail.com>2021-02-04 15:29:01 -0800
commit11a98f69dd3eaa28cc7d2c762ce29c1247de8931 (patch)
treef0ad84e9be10f08bed6cfe4650318c1756a39d17 /meta-networking
parent3cf7962581d7d3404762f98e20b5a2c404152dc1 (diff)
downloadmeta-openembedded-contrib-11a98f69dd3eaa28cc7d2c762ce29c1247de8931.tar.gz
net-snmp: Remove hardcoded paths to build host in net-snmp-config
New autconf detects that NSC_LDFLAGS are hardcoded to use -L/usr/lib therefore edit these variables during build so that they have cross-compile friendly values when net-snmp-config is used during build of dependent packages Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-protocols/net-snmp/net-snmp_5.9.bb18
1 files changed, 8 insertions, 10 deletions
diff --git a/meta-networking/recipes-protocols/net-snmp/net-snmp_5.9.bb b/meta-networking/recipes-protocols/net-snmp/net-snmp_5.9.bb
index 6a4d5b1eff..051e168f02 100644
--- a/meta-networking/recipes-protocols/net-snmp/net-snmp_5.9.bb
+++ b/meta-networking/recipes-protocols/net-snmp/net-snmp_5.9.bb
@@ -103,11 +103,10 @@ do_configure_prepend() {
}
do_configure_append() {
- if [ "${HAS_PERL}" = "1" ]; then
- sed -e "s@^NSC_INCLUDEDIR=.*@NSC_INCLUDEDIR=${STAGING_DIR_TARGET}\$\{includedir\}@g" \
- -e "s@^NSC_LIBDIR=-L.*@NSC_LIBDIR=-L${STAGING_DIR_TARGET}\$\{libdir\}@g" \
- -i ${B}/net-snmp-config
- fi
+ sed -e "s@^NSC_INCLUDEDIR=.*@NSC_INCLUDEDIR=${STAGING_DIR_TARGET}\$\{includedir\}@g" \
+ -e "s@^NSC_LIBDIR=-L.*@NSC_LIBDIR=-L${STAGING_DIR_TARGET}\$\{libdir\}@g" \
+ -e "s@^NSC_LDFLAGS=\"-L.* @NSC_LDFLAGS=\"-L${STAGING_DIR_TARGET}\$\{libdir\} @g" \
+ -i ${B}/net-snmp-config
}
do_install_append() {
@@ -135,11 +134,10 @@ do_install_append() {
sed -e 's@${STAGING_DIR_HOST}@@g' \
-i ${D}${libdir}/pkgconfig/netsnmp*.pc
- if [ "${HAS_PERL}" = "1" ]; then
- sed -e "s@^NSC_INCLUDEDIR=.*@NSC_INCLUDEDIR=\$\{includedir\}@g" \
- -e "s@^NSC_LIBDIR=-L.*@NSC_LIBDIR=-L\$\{libdir\}@g" \
- -i ${D}${bindir}/net-snmp-config
- fi
+ sed -e "s@^NSC_INCLUDEDIR=.*@NSC_INCLUDEDIR=\$\{includedir\}@g" \
+ -e "s@^NSC_LIBDIR=-L.*@NSC_LIBDIR=-L\$\{libdir\}@g" \
+ -e "s@^NSC_LDFLAGS=\"-L.* @NSC_LDFLAGS=\"-L\$\{libdir\} @g" \
+ -i ${D}${bindir}/net-snmp-config
oe_multilib_header net-snmp/net-snmp-config.h
}