aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2018-01-19 15:19:41 +0000
committerJoe MacDonald <joe_macdonald@mentor.com>2018-04-09 12:32:06 -0400
commitc75d215d9c22ae86c3f4ff15f88914b32295c95a (patch)
tree986fd6905a1ebc968322eb2b3842b2c9bc9fdd77 /meta-networking
parent6b16608c44108136c6d571eee128fdb579e9402e (diff)
downloadmeta-openembedded-contrib-c75d215d9c22ae86c3f4ff15f88914b32295c95a.tar.gz
freediameter: add dependency on virtual/kernel and use MACHINE_ARCH
* TUNE_PKGARCH cannot RRECOMMEND MACHINE specific kernel-modules * without virtual/kernel dependency (which isn't really build time dependency) the QA check won't traverse the dependencies correctly and shows following errors: ERROR: QA Issue: freediameter rdepends on kernel-module-ipip, but it isn't a build dependency? [build-deps] ERROR: QA Issue: freediameter rdepends on kernel-module-sctp, but it isn't a build dependency? [build-deps] ERROR: QA Issue: freediameter rdepends on kernel-module-tipc, but it isn't a build dependency? [build-deps] ERROR: QA Issue: freediameter rdepends on kernel-module-udp-tunnel, but it isn't a build dependency? [build-deps] * also change kernel-module dependencies from RDEPENDS to RRECOMMENDS because the kernel config might include these directly and then freediameter shouldn't fail to install Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-protocols/freediameter/freediameter_1.2.1.bb8
1 files changed, 5 insertions, 3 deletions
diff --git a/meta-networking/recipes-protocols/freediameter/freediameter_1.2.1.bb b/meta-networking/recipes-protocols/freediameter/freediameter_1.2.1.bb
index 92cd24c3ae..c556eb48e8 100644
--- a/meta-networking/recipes-protocols/freediameter/freediameter_1.2.1.bb
+++ b/meta-networking/recipes-protocols/freediameter/freediameter_1.2.1.bb
@@ -7,7 +7,9 @@ Accounting needs."
HOMEPAGE = "http://www.freediameter.net"
-DEPENDS = "flex bison cmake-native libgcrypt gnutls libidn lksctp-tools"
+DEPENDS = "flex bison cmake-native libgcrypt gnutls libidn lksctp-tools virtual/kernel"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
fd_pkgname = "freeDiameter"
@@ -121,8 +123,8 @@ FILES_${PN} += "${libdir}/${fd_pkgname}/*"
RDEPENDS_${PN} = "glib-2.0 gnutls libidn"
RDEPENDS_${PN} += "openssl openssl-conf openssl-engines"
-RDEPENDS_${PN} += "kernel-module-tipc kernel-module-sctp"
-RDEPENDS_${PN} += "kernel-module-udp-tunnel kernel-module-ipip"
+RRECOMMENDS_${PN} += "kernel-module-tipc kernel-module-sctp"
+RRECOMMENDS_${PN} += "kernel-module-udp-tunnel kernel-module-ipip"
RDEPENDS_${PN}-ptest = "cmake"
INITSCRIPT_PACKAGES = "${PN}"