aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-04-23 18:04:05 -0700
committerArmin Kuster <akuster808@gmail.com>2022-05-03 06:49:07 -0700
commit84560ca1cde0f0c0c7dafc6323c2559e8ef389b1 (patch)
treec457ceb63a9154cb43e9556e91d2fdbf85160c5c /meta-networking
parent594d95b226ce2d81866f8059bdec38bfce9d4543 (diff)
downloadmeta-openembedded-contrib-84560ca1cde0f0c0c7dafc6323c2559e8ef389b1.tar.gz
ufw: Fix build with usrmerge distro feature
Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit a47c833126334404fcad459cc683e304fee54595) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-connectivity/ufw/ufw_0.36.1.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/ufw/ufw_0.36.1.bb b/meta-networking/recipes-connectivity/ufw/ufw_0.36.1.bb
index 70216a85e3..6dca784bf4 100644
--- a/meta-networking/recipes-connectivity/ufw/ufw_0.36.1.bb
+++ b/meta-networking/recipes-connectivity/ufw/ufw_0.36.1.bb
@@ -38,6 +38,13 @@ RRECOMMENDS:${PN} = " \
kernel-module-nf-recent \
"
+
+do_configure:prepend() {
+ if ${@bb.utils.contains('DISTRO_FEATURES','usrmerge','true','false',d)}; then
+ sed -i -e 's|/lib|${nonarch_base_libdir}|' ${S}/setup.py
+ fi
+}
+
do_install:append() {
install -d ${D}${systemd_unitdir}/system/
install -m 0644 ${S}/doc/systemd.example ${D}${systemd_unitdir}/system/ufw.service