aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorStefan Schmidt <stefan.schmidt@huawei.com>2022-04-07 21:14:36 +0200
committerKhem Raj <raj.khem@gmail.com>2022-04-07 17:40:45 -0400
commit47640c2235ebfca8abfa1524087893e1ece095d5 (patch)
treecb2aadbb45fb56ffc4de258f83d351f05f270e59 /meta-networking
parentbb6a70a4638688ca971dc281d90627135f59ce0c (diff)
downloadmeta-openembedded-contrib-47640c2235ebfca8abfa1524087893e1ece095d5.tar.gz
ot-daemon: add recipe for OpenThread daemon
The OpenThread daemon allows Linuxes devices to participate in a Thread mesh network without acting as a full border router. The device participates like any other child or router devices within the network. This same repo is used for range of different modes to run the OpenThread code. From bare metal over vendor SDKs to posix platforms. For this recipe the focus is on the Linux posix implementation and we do not pull in all the git submodules on purpose. There are openthread enabled recipes in meta-zephyr for people who want to also use OpenThread on MCU based platforms on top of Zephyr. Signed-off-by: Stefan Schmidt <stefan.schmidt@huawei.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-connectivity/openthread/ot-daemon_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/openthread/ot-daemon_git.bb b/meta-networking/recipes-connectivity/openthread/ot-daemon_git.bb
new file mode 100644
index 0000000000..f3f4c70fa2
--- /dev/null
+++ b/meta-networking/recipes-connectivity/openthread/ot-daemon_git.bb
@@ -0,0 +1,27 @@
+# SPDX-FileCopyrightText: Huawei Inc.
+#
+# SPDX-License-Identifier: Apache-2.0
+SUMMARY = "OpenThread Daemon is an OpenThread POSIX build mode that runs OpenThread as a service."
+SECTION = "net"
+LICENSE = "BSD-3-Clause & Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=543b6fe90ec5901a683320a36390c65f \
+ file://third_party/mbedtls/repo/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
+ "
+DEPENDS = "readline"
+SRCREV = "7dfde1f12923f03c9680be4d838b94b7a2320324"
+PV = "0.1+git${SRCPV}"
+
+SRC_URI = "git://github.com/openthread/openthread.git;protocol=https;branch=main \
+ "
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+EXTRA_OECMAKE = "-DOT_DAEMON=ON \
+ -DOT_SPINEL_RESET_CONNECTION=ON \
+ -DOT_THREAD_VERSION=1.2 \
+ -DOT_COVERAGE=OFF \
+ -DOT_PLATFORM=posix \
+ -DCMAKE_BUILD_TYPE=Release \
+ "