aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2022-03-16 22:02:13 +0800
committerKhem Raj <raj.khem@gmail.com>2022-03-17 08:18:31 -0700
commit0dd33989a83b411b9aebcac45feec0738faed430 (patch)
tree1a835630c1dd4e1231324d2bf524040fe6fa8460 /meta-networking
parentb4b29dd6a7a648735c4d43b19a2e838e138b033d (diff)
downloadmeta-openembedded-contrib-0dd33989a83b411b9aebcac45feec0738faed430.tar.gz
netplan: fix parallel build failure
Backport a patch to fix the parallel build failure: src/dbus.c:17:10: fatal error: _features.h: No such file or directory Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-connectivity/netplan/netplan/0001-Makefile-fix-parallel-build-failure.patch44
-rw-r--r--meta-networking/recipes-connectivity/netplan/netplan_0.104.bb1
2 files changed, 45 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/netplan/netplan/0001-Makefile-fix-parallel-build-failure.patch b/meta-networking/recipes-connectivity/netplan/netplan/0001-Makefile-fix-parallel-build-failure.patch
new file mode 100644
index 0000000000..2149ee30cd
--- /dev/null
+++ b/meta-networking/recipes-connectivity/netplan/netplan/0001-Makefile-fix-parallel-build-failure.patch
@@ -0,0 +1,44 @@
+From 2e84550b47b475d830622f41576992a1d45d6af0 Mon Sep 17 00:00:00 2001
+From: Zhao Yi <38274519+yizhao1@users.noreply.github.com>
+Date: Tue, 15 Mar 2022 19:28:26 +0800
+Subject: [PATCH] Makefile: fix parallel build failure (#267)
+
+* Makefile: fix parallel build failure
+
+Add src/_features.h as dependency for dbus.o to fix the parallel build
+failure:
+src/dbus.c:17:10: fatal error: _features.h: No such file or directory
+
+Upstream-Status: Backport
+[https://github.com/canonical/netplan/commit/2e84550b47b475d830622f41576992a1d45d6af0]
+
+Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
+---
+ Makefile | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 0368e41..8ac7432 100644
+--- a/Makefile
++++ b/Makefile
+@@ -52,7 +52,7 @@ NOSETESTS3 ?= $(shell command -v nosetests-3 || command -v nosetests3 || echo tr
+
+ default: netplan/_features.py generate netplan-dbus dbus/io.netplan.Netplan.service doc/netplan.html doc/netplan.5 doc/netplan-generate.8 doc/netplan-apply.8 doc/netplan-try.8 doc/netplan-dbus.8 doc/netplan-get.8 doc/netplan-set.8
+
+-%.o: src/%.c
++%.o: src/%.c src/_features.h
+ $(CC) $(BUILDFLAGS) $(CFLAGS) $(LDFLAGS) -c $^ `pkg-config --cflags --libs glib-2.0 gio-2.0 yaml-0.1 uuid`
+
+ libnetplan.so.$(NETPLAN_SOVER): $(SRCS) abicompat.lds
+@@ -62,7 +62,7 @@ libnetplan.so.$(NETPLAN_SOVER): $(SRCS) abicompat.lds
+ generate: libnetplan.so.$(NETPLAN_SOVER) generate.o
+ $(CC) $(BUILDFLAGS) $(CFLAGS) $(LDFLAGS) -o $@ $(filter-out $<,$^) -L. -lnetplan `pkg-config --cflags --libs glib-2.0 gio-2.0 yaml-0.1 uuid`
+
+-netplan-dbus: libnetplan.so.$(NETPLAN_SOVER) src/_features.h dbus.o
++netplan-dbus: libnetplan.so.$(NETPLAN_SOVER) dbus.o
+ $(CC) $(BUILDFLAGS) $(CFLAGS) $(LDFLAGS) -o $@ $(filter-out $<,$(patsubst %.h,,$^)) -L. -lnetplan `pkg-config --cflags --libs libsystemd glib-2.0 gio-2.0 yaml-0.1 uuid`
+
+ src/_features.h: src/[^_]*.[hc]
+--
+2.25.1
+
diff --git a/meta-networking/recipes-connectivity/netplan/netplan_0.104.bb b/meta-networking/recipes-connectivity/netplan/netplan_0.104.bb
index e19fceb4ae..ea944fa9db 100644
--- a/meta-networking/recipes-connectivity/netplan/netplan_0.104.bb
+++ b/meta-networking/recipes-connectivity/netplan/netplan_0.104.bb
@@ -16,6 +16,7 @@ PV = "0.104"
SRC_URI = "git://github.com/CanonicalLtd/netplan.git;branch=main;protocol=https \
file://0001-Makefile-do-not-use-Werror.patch \
+ file://0001-Makefile-fix-parallel-build-failure.patch \
"
SRC_URI:append:libc-musl = " file://0001-don-t-fail-if-GLOB_BRACE-is-not-defined.patch"