aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2022-02-23 07:44:46 +0800
committerKhem Raj <raj.khem@gmail.com>2022-02-23 09:25:19 -0800
commit6ed9d2d546ae1a70df148483f4a0f28ce429e90a (patch)
tree8ea0e3072077b523434698eab9f246a165eda305 /meta-networking
parent124c19a0a661615468482f82b52d6c254517a4ff (diff)
downloadmeta-openembedded-contrib-6ed9d2d546ae1a70df148483f4a0f28ce429e90a.tar.gz
netplan: upgrade 0.103 -> 0.104
refresh patches for 0.104: 0001-Makefile-do-not-use-Werror.patch 0001-don-t-fail-if-GLOB_BRACE-is-not-defined.patch 0001-parse-nm-fix-32bit-format-string.patch removed since it's included in 0.104 Changelog: ========= Enable embedded-switch-mode setting on SmartNICs (#253) Permit multiple patterns for the driver globs in match (#202), LP#1918421 Improve routing capabilities (#248), LP#1892272, LP#1805038 Support additional link offload options for networkd (#225) (#242), LP#1771740 Consolidate enum-to-string arrays (#230) Handle differing ip6-privacy default value for NetworkManager (#263) YAML state tracking (--state rootdir) for DBus API and netplan try (#231), LP#1943120 Support ConfigureWithoutCarrier (ignore-carrier) for networkd (#215) Move primary git branch master to main Documentation improvements (#226) Compatibility for glib-2.70 (#235) Cleanup Makefile, install only public headers Improve test reliability & enable integration testing CI for autopkgtests Netplan get to use the libnetplan parser (#252) libnetplan: - introduce the notion of NetplanState (#232) - use an explicit parser context (#233) - expose coherent generator APIs (#239) - improve overall error handling (#234) - consolidation of YAML parsing into the library (#241, #249, #250, #251) Restrict the symbol export to a determined public API (#227) - WARNING: We dropped some internal symbols from the API that we know have no external consumers (that we are aware of) - 0.103: _serialize_yaml, contains_netdef_type, tmp, validate_default_route_consistency - 0.102: cur_filename, netplan_netdef_new - 0.100: address_option_handlers, is_hostname, validate_ovs_target, wireguard_peer_handlers - 0.99: current_file, is_ip4_address, is_ip6_address, missing_id, missing_ids_found, parser_error, validate_backend_rules, validate_netdef_grammar, yaml_error Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-connectivity/netplan/netplan/0001-Makefile-do-not-use-Werror.patch11
-rw-r--r--meta-networking/recipes-connectivity/netplan/netplan/0001-don-t-fail-if-GLOB_BRACE-is-not-defined.patch16
-rw-r--r--meta-networking/recipes-connectivity/netplan/netplan/0001-parse-nm-fix-32bit-format-string.patch25
-rw-r--r--meta-networking/recipes-connectivity/netplan/netplan_0.104.bb (renamed from meta-networking/recipes-connectivity/netplan/netplan_0.103.bb)5
4 files changed, 18 insertions, 39 deletions
diff --git a/meta-networking/recipes-connectivity/netplan/netplan/0001-Makefile-do-not-use-Werror.patch b/meta-networking/recipes-connectivity/netplan/netplan/0001-Makefile-do-not-use-Werror.patch
index ddc44c3ca0..613858f6fd 100644
--- a/meta-networking/recipes-connectivity/netplan/netplan/0001-Makefile-do-not-use-Werror.patch
+++ b/meta-networking/recipes-connectivity/netplan/netplan/0001-Makefile-do-not-use-Werror.patch
@@ -10,14 +10,17 @@ Signed-off-by: Alexander Kanavin <alex@linutronix.de>
1 file changed, 1 deletion(-)
diff --git a/Makefile b/Makefile
-index 8645aee..50fc0da 100644
+index 0368e41..53d6a9d 100644
--- a/Makefile
+++ b/Makefile
-@@ -7,7 +7,6 @@ BUILDFLAGS = \
- -D_XOPEN_SOURCE=500 \
+@@ -8,7 +8,6 @@ BUILDFLAGS = \
-DSBINDIR=\"$(SBINDIR)\" \
+ -I${CURDIR}/include \
-Wall \
- -Werror \
$(NULL)
- SYSTEMD_GENERATOR_DIR=$(shell pkg-config --variable=systemdsystemgeneratordir systemd)
+ SRCS = \
+--
+2.25.1
+
diff --git a/meta-networking/recipes-connectivity/netplan/netplan/0001-don-t-fail-if-GLOB_BRACE-is-not-defined.patch b/meta-networking/recipes-connectivity/netplan/netplan/0001-don-t-fail-if-GLOB_BRACE-is-not-defined.patch
index c7d371dfa0..8779c251a5 100644
--- a/meta-networking/recipes-connectivity/netplan/netplan/0001-don-t-fail-if-GLOB_BRACE-is-not-defined.patch
+++ b/meta-networking/recipes-connectivity/netplan/netplan/0001-don-t-fail-if-GLOB_BRACE-is-not-defined.patch
@@ -4,18 +4,17 @@ Date: Fri, 25 Dec 2020 11:41:43 +0900
Subject: [PATCH] don't fail if GLOB_BRACE is not defined
Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com>
-
---
src/util.c | 6 ++++++
1 file changed, 6 insertions(+)
diff --git a/src/util.c b/src/util.c
-index a4c0dba..fd4542d 100644
+index 841ec12..59595da 100644
--- a/src/util.c
+++ b/src/util.c
-@@ -25,6 +25,12 @@
- #include "util.h"
- #include "netplan.h"
+@@ -32,6 +32,12 @@
+ #include "names.h"
+ #include "yaml-helpers.h"
+/* Don't fail if the standard library
+ * doesn't provide brace expansion */
@@ -23,6 +22,9 @@ index a4c0dba..fd4542d 100644
+#define GLOB_BRACE 0
+#endif
+
- GHashTable* wifi_frequency_24;
- GHashTable* wifi_frequency_5;
+ NETPLAN_ABI GHashTable*
+ wifi_frequency_24;
+--
+2.25.1
+
diff --git a/meta-networking/recipes-connectivity/netplan/netplan/0001-parse-nm-fix-32bit-format-string.patch b/meta-networking/recipes-connectivity/netplan/netplan/0001-parse-nm-fix-32bit-format-string.patch
deleted file mode 100644
index 72f04a15ad..0000000000
--- a/meta-networking/recipes-connectivity/netplan/netplan/0001-parse-nm-fix-32bit-format-string.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 2f0ff65eaa93f18d9edb5d03329b00d8e5e73869 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Lukas=20M=C3=A4rdian?= <lukas.maerdian@canonical.com>
-Date: Wed, 4 Aug 2021 15:55:00 +0200
-Subject: [PATCH] parse-nm: fix 32bit format string
-
----
- src/parse-nm.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/parse-nm.c b/src/parse-nm.c
-index 9b09e34..bf998b7 100644
---- a/src/parse-nm.c
-+++ b/src/parse-nm.c
-@@ -136,7 +136,7 @@ static void
- handle_bridge_uint(GKeyFile* kf, const gchar* key, NetplanNetDefinition* nd, char** dataptr) {
- if (g_key_file_get_uint64(kf, "bridge", key, NULL)) {
- nd->custom_bridging = TRUE;
-- *dataptr = g_strdup_printf("%lu", g_key_file_get_uint64(kf, "bridge", key, NULL));
-+ *dataptr = g_strdup_printf("%"G_GUINT64_FORMAT, g_key_file_get_uint64(kf, "bridge", key, NULL));
- _kf_clear_key(kf, "bridge", key);
- }
- }
---
-2.25.1
-
diff --git a/meta-networking/recipes-connectivity/netplan/netplan_0.103.bb b/meta-networking/recipes-connectivity/netplan/netplan_0.104.bb
index 81e20b9c8e..6a32f55d47 100644
--- a/meta-networking/recipes-connectivity/netplan/netplan_0.103.bb
+++ b/meta-networking/recipes-connectivity/netplan/netplan_0.104.bb
@@ -11,11 +11,10 @@ LICENSE = "GPLv3"
LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
S = "${WORKDIR}/git"
-SRCREV = "51c872d856db80281ea810ebc02e05c09d5310fa"
-PV = "0.103"
+SRCREV = "3e522b7255310bdecca6c781137741dfc4abc021"
+PV = "0.104"
SRC_URI = "git://github.com/CanonicalLtd/netplan.git;branch=main;protocol=https \
- file://0001-parse-nm-fix-32bit-format-string.patch \
file://0001-Makefile-do-not-use-Werror.patch \
"