aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorAthanasios Oikonomou <athoik@gmail.com>2017-09-07 00:16:42 +0300
committerJoe MacDonald <joe_macdonald@mentor.com>2017-09-12 10:55:09 -0400
commit30d389c2f11695686a72de4bb315b45eaa7564e8 (patch)
tree73a4bd798a7cc09a61effc4a34e0af088b932860 /meta-networking
parente4e77d204072b0c9028cbdac40559f61e818e0a9 (diff)
downloadmeta-openembedded-contrib-30d389c2f11695686a72de4bb315b45eaa7564e8.tar.gz
vsftpd: link with wrap when tcp-wrappers configured
By default we do not build vsftpd with tcp-wrappers, so we should not include lib wrap. Make lib wrap optional depending on tcp-wrappers PACKAGECONFIG. Signed-off-by: Athanasios Oikonomou <athoik@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.3.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.3.bb b/meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.3.bb
index e524614464..7a20356018 100644
--- a/meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.3.bb
+++ b/meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.3.bb
@@ -37,6 +37,7 @@ PACKAGECONFIG[tcp-wrappers] = ",,tcp-wrappers"
DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
RDEPENDS_${PN} += "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'pam-plugin-listfile', '', d)}"
PAMLIB = "${@bb.utils.contains('DISTRO_FEATURES', 'pam', '-L${STAGING_BASELIBDIR} -lpam', '', d)}"
+WRAPLIB = "${@bb.utils.contains('PACKAGECONFIG', 'tcp-wrappers', '-lwrap', '', d)}"
NOPAM_SRC ="${@bb.utils.contains('PACKAGECONFIG', 'tcp-wrappers', 'file://nopam-with-tcp_wrappers.patch', 'file://nopam.patch', d)}"
inherit update-rc.d useradd systemd
@@ -54,7 +55,7 @@ do_configure() {
}
do_compile() {
- oe_runmake "LIBS=-L${STAGING_LIBDIR} -lcrypt -lcap ${PAMLIB} -lwrap"
+ oe_runmake "LIBS=-L${STAGING_LIBDIR} -lcrypt -lcap ${PAMLIB} ${WRAPLIB}"
}
do_install() {