aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorCarlos Rafael Giani <dv@pseudoterminal.org>2018-07-15 17:46:43 +0200
committerKhem Raj <raj.khem@gmail.com>2018-07-15 11:58:02 -0700
commit2de6f8d1b4608dbdce391c3d89d01402eb641f52 (patch)
tree28a0a063ce73103fee81a39c3201ca3ae647087e /meta-networking
parentcccf8fc305fb3da9bdaf26284488f03698b986dc (diff)
downloadmeta-openembedded-contrib-2de6f8d1b4608dbdce391c3d89d01402eb641f52.tar.gz
nanomsg: add recipe
nanomsg is a socket library that provides several common communication patterns. It is a rewrite of the ZeroMQ library. For differences between ZeroMQ and nanomsg, consult https://nanomsg.org/documentation-zeromq.html Signed-off-by: Carlos Rafael Giani <dv@pseudoterminal.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-connectivity/nanomsg/nanomsg_1.1.4.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/nanomsg/nanomsg_1.1.4.bb b/meta-networking/recipes-connectivity/nanomsg/nanomsg_1.1.4.bb
new file mode 100644
index 0000000000..fa6b43ace9
--- /dev/null
+++ b/meta-networking/recipes-connectivity/nanomsg/nanomsg_1.1.4.bb
@@ -0,0 +1,28 @@
+SUMMARY = "nanomsg socket library"
+DESCRIPTION = "nanomsg is a socket library that provides several common \
+communication patterns. It aims to make the networking layer fast, scalable, \
+and easy to use. Implemented in C, it works on a wide range of operating \
+systems with no further dependencies."
+HOMEPAGE = "https://nanomsg.org/"
+LICENSE = "MIT-X"
+LIC_FILES_CHKSUM = "file://COPYING;md5=587b3fd7fd291e418ff4d2b8f3904755"
+
+SECTION = "libs/networking"
+
+SRC_URI = "git://github.com/nanomsg/nanomsg.git;protocol=https"
+SRCREV = "e7f8a751316b942d8962cd0232c2d606c1d9a9db"
+
+S = "${WORKDIR}/git"
+
+inherit cmake pkgconfig
+
+# nanomsg documentation generation requires asciidoctor,
+# not asciidoc, and currently there's no asciidoctor-native
+# recipe anywhere in openembedded-core or meta-openembedded
+EXTRA_OECMAKE = " -DNN_ENABLE_DOC=OFF "
+
+# we don't want nanomsg-tools to be renamed to libnanomsg-tools
+DEBIAN_NOAUTONAME_${PN}-tools = "1"
+
+PACKAGES =+ "${PN}-tools"
+FILES_${PN}-tools = "${bindir}/*"