aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-07-26 11:58:11 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-08-31 14:59:50 +0200
commit82bf54421b427754f23bc9a97984340465293a4f (patch)
tree7ee2594a1db83896ead2376900c19d334ede164a /meta-networking
parentf636b27550302941a82c06c95a03f7900483e98a (diff)
downloadmeta-openembedded-contrib-82bf54421b427754f23bc9a97984340465293a4f.tar.gz
libesmtp: Fix config.h define for snprintf detection
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/libesmtp/libesmtp/snprintf.patch19
-rw-r--r--meta-networking/recipes-support/libesmtp/libesmtp_1.0.6.bb4
2 files changed, 22 insertions, 1 deletions
diff --git a/meta-networking/recipes-support/libesmtp/libesmtp/snprintf.patch b/meta-networking/recipes-support/libesmtp/libesmtp/snprintf.patch
new file mode 100644
index 0000000000..d0d203eadb
--- /dev/null
+++ b/meta-networking/recipes-support/libesmtp/libesmtp/snprintf.patch
@@ -0,0 +1,19 @@
+Use HAVE_WORKING_SNPRINTF to check for snprintf()
+
+Upstream-Status: Pending
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Index: libesmtp-1.0.6/missing.h
+===================================================================
+--- libesmtp-1.0.6.orig/missing.h
++++ libesmtp-1.0.6/missing.h
+@@ -43,7 +43,7 @@ int strncasecmp (const char *a, const ch
+ void *memrchr (const void *a, int c, size_t len);
+ #endif
+
+-#ifndef HAVE_SNPRINTF
++#ifndef HAVE_WORKING_SNPRINTF
+ #include <sys/types.h>
+ int snprintf(char *s, size_t n, const char *format, ...);
+ #endif
diff --git a/meta-networking/recipes-support/libesmtp/libesmtp_1.0.6.bb b/meta-networking/recipes-support/libesmtp/libesmtp_1.0.6.bb
index 7ddf591eb6..71c5d940b7 100644
--- a/meta-networking/recipes-support/libesmtp/libesmtp_1.0.6.bb
+++ b/meta-networking/recipes-support/libesmtp/libesmtp_1.0.6.bb
@@ -9,7 +9,9 @@ SECTION = "libs"
DEPENDS = "openssl"
SRC_URI = "http://www.stafford.uklinux.net/libesmtp/libesmtp-${PV}.tar.bz2 \
- file://include-topdir.patch"
+ file://include-topdir.patch \
+ file://snprintf.patch \
+ "
SRC_URI[md5sum] = "bf3915e627fd8f35524a8fdfeed979c8"
SRC_URI[sha256sum] = "d0a61a5c52d99fa7ce7d00ed0a07e341dbda67101dbed1ab0cdae3f37db4eb0b"