aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorMariano Lopez <just.another.mariano@gmail.com>2019-07-23 20:01:46 -0500
committerKhem Raj <raj.khem@gmail.com>2019-07-23 18:39:29 -0700
commita8f362deb33958b9be2a38b626242a4174e15f4f (patch)
tree5e3c640c3b9c991cd85390d103ff5622852d9ad5 /meta-networking
parent915098ffaec33087c552bacf6393e3fcac24ef9c (diff)
downloadmeta-openembedded-contrib-a8f362deb33958b9be2a38b626242a4174e15f4f.tar.gz
nftables: 0.9.0 > 0.9.1
The upgrade includes a new python library, therefore added the {PN}-python package. Signed-off-by: Mariano López <just.another.mariano@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-filter/nftables/nftables_0.9.1.bb (renamed from meta-networking/recipes-filter/nftables/nftables_0.9.0.bb)16
1 files changed, 11 insertions, 5 deletions
diff --git a/meta-networking/recipes-filter/nftables/nftables_0.9.0.bb b/meta-networking/recipes-filter/nftables/nftables_0.9.1.bb
index 3ff9583fcc..9d0da33e37 100644
--- a/meta-networking/recipes-filter/nftables/nftables_0.9.0.bb
+++ b/meta-networking/recipes-filter/nftables/nftables_0.9.1.bb
@@ -7,16 +7,22 @@ DEPENDS = "libmnl libnftnl readline gmp bison-native"
UPSTREAM_CHECK_URI = "https://www.netfilter.org/projects/nftables/files/"
-SRC_URI = "http://www.netfilter.org/projects/nftables/files/${BP}.tar.bz2 \
- "
-SRC_URI[md5sum] = "d4dcb61df80aa544b2e142e91d937635"
-SRC_URI[sha256sum] = "ad8181b5fcb9ca572f444bed54018749588522ee97e4c21922648bb78d7e7e91"
+SRC_URI = "http://www.netfilter.org/projects/nftables/files/${BP}.tar.bz2"
+SRC_URI[md5sum] = "e2facbcad6c5d9bd87a0bf5081a31522"
+SRC_URI[sha256sum] = "ead3bb68ed540bfbb87a96f2b69c3d65ab0c2a0c3f6e739a395c09377d1b4fce"
inherit autotools manpages pkgconfig
-PACKAGECONFIG ?= ""
+PACKAGECONFIG ?= "python"
PACKAGECONFIG[man] = "--enable--man-doc, --disable-man-doc"
+PACKAGECONFIG[python] = "--with-python-bin=${PYTHON}, --with-python-bin="", python3"
+
+inherit ${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3native', '', d)}
ASNEEDED = ""
RRECOMMENDS_${PN} += "kernel-module-nf-tables"
+
+PACKAGES =+ "${PN}-python"
+FILES_${PN}-python = "${libdir_native}/${PYTHON_DIR}"
+RDEPENDS_${PN}-python = "python3-core python3-json"