aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2019-08-12 07:34:32 +0000
committerKhem Raj <raj.khem@gmail.com>2019-08-12 09:11:01 -0700
commit7cede6b863fc0de245b4b7f0071ac38d2059b0af (patch)
tree5053b4a67fff073e0eb03ba6efbce6daee04ea2d /meta-networking
parentd3579d05db727d8ab112e7583c094e922b21a593 (diff)
downloadmeta-openembedded-contrib-7cede6b863fc0de245b4b7f0071ac38d2059b0af.tar.gz
ntop: fix missing return from non-void function
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/ntop/ntop/fix-missing-return-from-non-void-function.patch19
-rw-r--r--meta-networking/recipes-support/ntop/ntop_5.0.1.bb1
2 files changed, 20 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/ntop/ntop/fix-missing-return-from-non-void-function.patch b/meta-networking/recipes-support/ntop/ntop/fix-missing-return-from-non-void-function.patch
new file mode 100644
index 0000000000..e627e59a59
--- /dev/null
+++ b/meta-networking/recipes-support/ntop/ntop/fix-missing-return-from-non-void-function.patch
@@ -0,0 +1,19 @@
+Fix following error:
+
+netflowPlugin.c: In function 'netflowUtilsLoop':
+netflowPlugin.c:2144:1: error: no return statement in function returning non-void [-Werror=return-type]
+ 2144 | }
+ | ^
+
+Return NULL like netflowMainLoop does.
+
+--- ntop-5.0.1.orig/plugins/netflowPlugin.c 2012-03-09 17:44:17.000000000 +0000
++++ ntop-5.0.1/plugins/netflowPlugin.c 2019-08-09 10:25:40.878799852 +0000
+@@ -2141,6 +2141,7 @@
+ waitCondvar(&myGlobals.device[deviceId].netflowGlobals->ifStatsQueueCondvar);
+ }
+ }
++ return(NULL);
+ }
+ #endif
+
diff --git a/meta-networking/recipes-support/ntop/ntop_5.0.1.bb b/meta-networking/recipes-support/ntop/ntop_5.0.1.bb
index 2a7a7f2cb0..80f009b7c3 100644
--- a/meta-networking/recipes-support/ntop/ntop_5.0.1.bb
+++ b/meta-networking/recipes-support/ntop/ntop_5.0.1.bb
@@ -18,6 +18,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/ntop/ntop-${PV}.tar.gz \
file://use-static-inline.patch \
file://0001-nDPI-Include-sys-types.h.patch \
file://0001-plugins-Makefile.am-fix-for-automake-1.16.1.patch \
+ file://fix-missing-return-from-non-void-function.patch \
"
SRC_URI[md5sum] = "01710b6925a8a5ffe1a41b8b512ebd69"
SRC_URI[sha256sum] = "7e8e84cb14d2173beaca4d4cb991a14d84a4bef84ec37b2276bc363f45c52ef8"