aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorWenzong Fan <wenzong.fan@windriver.com>2015-09-23 23:12:31 -0400
committerJoe MacDonald <joe_macdonald@mentor.com>2015-10-21 15:57:26 -0400
commitb851e928eacb9c27923a9028618d107fe22136fd (patch)
tree2760af48c0b1032325c1f948aa6cf7f42994b3ce /meta-networking
parent0289eac721085563ff727515022e8c61b2ecf30d (diff)
downloadmeta-openembedded-contrib-b851e928eacb9c27923a9028618d107fe22136fd.tar.gz
squid: disable atomic operations for powerpc/mips
Don't enable GNU atomic operations for all targets, it fails on powerpc and mips: AtomicWord.h: undefined reference to `__sync_fetch_and_add_8' collect2: error: ld returned 1 exit status Refer to https://gcc.gnu.org/bugzilla/show_bug.cgi?id=56300: There is no hardware support for 8 bytes atomic operations on 32-bit MIPS targets. The 32-bit PowerPC fails as well. Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-daemons/squid/squid_3.5.7.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/meta-networking/recipes-daemons/squid/squid_3.5.7.bb b/meta-networking/recipes-daemons/squid/squid_3.5.7.bb
index 5d058dc265..5b27d4639e 100644
--- a/meta-networking/recipes-daemons/squid/squid_3.5.7.bb
+++ b/meta-networking/recipes-daemons/squid/squid_3.5.7.bb
@@ -34,8 +34,11 @@ inherit autotools useradd ptest
USERADD_PACKAGES = "${PN}"
USERADD_PARAM_${PN} = "--system --no-create-home --home-dir /var/run/squid --shell /bin/false --user-group squid"
-PACKAGECONFIG ??= ""
+PACKAGECONFIG ??= "${@base_contains('TARGET_ARCH', 'powerpc', 'noatomics', '', d)} \
+ ${@base_contains('TARGET_ARCH', 'mips', 'noatomics', '', d)} \
+ "
PACKAGECONFIG[libnetfilter-conntrack] = "--with-netfilter-conntrack=${includedir}, --without-netfilter-conntrack, libnetfilter-conntrack"
+PACKAGECONFIG[noatomics] = "squid_cv_gnu_atomics=no,squid_cv_gnu_atomics=yes,,"
BASIC_AUTH = "DB SASL LDAP NIS"
DEPENDS += "${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
@@ -43,7 +46,6 @@ BASIC_AUTH += "${@base_contains('DISTRO_FEATURES', 'pam', 'PAM', '', d)}"
EXTRA_OECONF += "--with-default-user=squid --enable-auth-basic='${BASIC_AUTH}'"
export BUILDCXXFLAGS="${BUILD_CXXFLAGS}"
-CACHED_CONFIGUREVARS += "squid_cv_gnu_atomics=yes"
TESTDIR = "test-suite"
do_compile_ptest() {