aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorQi.Chen@windriver.com <Qi.Chen@windriver.com>2017-05-23 17:05:49 +0800
committerJoe MacDonald <joe_macdonald@mentor.com>2017-06-28 10:25:43 -0400
commitc2cedc59121ddf4564c5884f1ed80037610f95c9 (patch)
tree65bb45e6ba8ad7aea25dcd0c9605c9e0f9c91889 /meta-networking
parent0f9bd5642ba8d36f09cbabafb7317ca4eb03c2b5 (diff)
downloadmeta-openembedded-contrib-c2cedc59121ddf4564c5884f1ed80037610f95c9.tar.gz
open-isns: fix QA issue
Fix the following QA issue. ERROR: open-isns-0.97-r0 do_package: QA Issue: open-isns: Files/directories were installed but not shipped in any package: /usr/lib /usr/lib/systemd /usr/lib/systemd/system /usr/lib/systemd/system/isnsd.socket /usr/lib/systemd/system/isnsd.service Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/open-isns/open-isns_0.97.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-networking/recipes-support/open-isns/open-isns_0.97.bb b/meta-networking/recipes-support/open-isns/open-isns_0.97.bb
index 828d1166de..420ef5be00 100644
--- a/meta-networking/recipes-support/open-isns/open-isns_0.97.bb
+++ b/meta-networking/recipes-support/open-isns/open-isns_0.97.bb
@@ -26,10 +26,11 @@ inherit systemd autotools-brokensep distro_features_check
REQUIRED_DISTRO_FEATURES = "systemd"
EXTRA_OECONF = " --prefix=${prefix} --enable-shared"
+EXTRA_OEMAKE += "SYSTEMDDIR=${D}${systemd_unitdir}/system"
do_install_append () {
oe_runmake INCDIR=${D}${includedir}/libisns/ install_hdrs
oe_runmake LIBDIR=${D}${libdir} install_lib
}
-FILES_${PN} += "${libdir}"
+FILES_${PN} += "${libdir} ${systemd_unitdir}"