aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authormike.looijmans@topic.nl <mike.looijmans@topic.nl>2016-10-07 08:36:17 +0200
committerJoe MacDonald <joe_macdonald@mentor.com>2016-10-20 11:18:07 -0400
commitb850fda09a4c3d97ef3c6ae66fd9745c4ccbf922 (patch)
tree939447df9a4169d7d2f4dab8e4d4a4ab53310073 /meta-networking
parent8eef5ab5cd66b349dd517cbcc3db355963232d9c (diff)
downloadmeta-openembedded-contrib-b850fda09a4c3d97ef3c6ae66fd9745c4ccbf922.tar.gz
phytool: Add recipe
A nice tool to directly read, write and interpret ethernet PHY data. Very useful when debugging PHY or MDIO problems, which ethtool does not do. Signed-off-by: Mike Looijmans <mike.looijmans@topic.nl> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/phytool/phytool.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/phytool/phytool.bb b/meta-networking/recipes-support/phytool/phytool.bb
new file mode 100644
index 0000000000..4ed3ed1e40
--- /dev/null
+++ b/meta-networking/recipes-support/phytool/phytool.bb
@@ -0,0 +1,15 @@
+SUMMARY = "PHY interface tool for Linux"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=39bba7d2cf0ba1036f2a6e2be52fe3f0"
+
+PV = "1.0.1+git${SRCPV}"
+SRCREV = "3149bfdb4f513e2f0da0a7d0bc5d0873578696f2"
+SRC_URI = "git://github.com/wkz/phytool.git"
+
+S = "${WORKDIR}/git"
+
+# The Makefile has "$PREFIX/bin" hardcoded into it, hence not using $bindir here
+do_install() {
+ install -d ${D}${prefix}/bin
+ oe_runmake 'DESTDIR=${D}' 'PREFIX=${prefix}' install
+}