aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2016-09-15 15:50:23 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2016-09-26 08:29:09 +0200
commit82f2e2b69e2c0c04b2fff357260bc36be08f0752 (patch)
tree2115a39a79714dfc57de64f2852262cd0497b33d /meta-networking
parente05536ca6835944e80df61c82bfe60d423c7c193 (diff)
downloadmeta-openembedded-contrib-82f2e2b69e2c0c04b2fff357260bc36be08f0752.tar.gz
chrony: add PACKAGECONFIG for nss, libcap
* fixes autodetected dependencies http://logs.nslu2-linux.org/buildlogs/oe/world/log.report.20160905_011801.log chrony-2.4: chronyc rdepends on nss, but it isn't a build dependency, missing nss in DEPENDS or PACKAGECONFIG? [build-deps] chrony-2.4: chrony rdepends on libcap, but it isn't a build dependency, missing libcap in DEPENDS or PACKAGECONFIG? [build-deps] chrony-2.4: chrony rdepends on nss, but it isn't a build dependency, missing nss in DEPENDS or PACKAGECONFIG? [build-deps] * also use PACKAGECONFIG_CONFARGS instead of EXTRA_OECONF in do_configure Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/chrony/chrony_2.4.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta-networking/recipes-support/chrony/chrony_2.4.bb b/meta-networking/recipes-support/chrony/chrony_2.4.bb
index 4bc4ce0df1..a8898dc80d 100644
--- a/meta-networking/recipes-support/chrony/chrony_2.4.bb
+++ b/meta-networking/recipes-support/chrony/chrony_2.4.bb
@@ -67,6 +67,8 @@ PACKAGECONFIG[sechash] = "--without-tomcrypt,--disable-sechash,nss"
PACKAGECONFIG[privdrop] = ",--disable-privdrop,libcap"
PACKAGECONFIG[scfilter] = "--enable-scfilter,--without-seccomp"
PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
+PACKAGECONFIG[nss] = "--with-nss,--without-nss,nss"
+PACKAGECONFIG[libcap] = "--with-libcap,--without-libcap,libcap"
# --disable-static isn't supported by chrony's configure script.
DISABLE_STATIC = ""
@@ -74,7 +76,7 @@ DISABLE_STATIC = ""
do_configure() {
./configure --sysconfdir=${sysconfdir} --bindir=${bindir} --sbindir=${sbindir} \
--localstatedir=${localstatedir} --datarootdir=${datadir} \
- ${EXTRA_OECONF}
+ ${PACKAGECONFIG_CONFARGS}
}
do_install() {