aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-04-01 08:36:37 -0700
committerJoe MacDonald <joe_macdonald@mentor.com>2017-04-25 15:55:37 -0400
commit1543614e940c08c15914934aab8cdc243c9a3ed2 (patch)
tree6c7b76e3a53cb0a50fd23867cfa6c31c098e04f6 /meta-networking
parent488214259d17acfda308f821350630ea4ff359ae (diff)
downloadmeta-openembedded-contrib-1543614e940c08c15914934aab8cdc243c9a3ed2.tar.gz
ntimed: Use adjtimex on musl
Drop do_compile, default is same Do not assume that configure is running in S Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/ntimed/ntimed_git.bb9
1 files changed, 4 insertions, 5 deletions
diff --git a/meta-networking/recipes-support/ntimed/ntimed_git.bb b/meta-networking/recipes-support/ntimed/ntimed_git.bb
index dac5617545..527ea33b55 100644
--- a/meta-networking/recipes-support/ntimed/ntimed_git.bb
+++ b/meta-networking/recipes-support/ntimed/ntimed_git.bb
@@ -16,6 +16,9 @@ SRCREV = "db0abbb4c80f2ecef6bc5d9639bca5bea28532a2"
S = "${WORKDIR}/git"
+# use adjtimex on musl
+CFLAGS_append_libc-musl = " -Dntp_adjtime=adjtimex"
+
EXTRA_OEMAKE = "\
'CC=${CC}' \
'CFLAGS=${CFLAGS}' \
@@ -23,11 +26,7 @@ EXTRA_OEMAKE = "\
"
do_configure () {
- sh ./configure
-}
-
-do_compile () {
- oe_runmake
+ sh ${S}/configure
}
do_install () {