aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorFabio Berton <fabio.berton@ossystems.com.br>2017-10-31 17:51:22 -0200
committerJoe MacDonald <joe_macdonald@mentor.com>2018-01-08 11:53:44 -0500
commitf122ecd7171b2258452131cc75d809b02a1f4f02 (patch)
tree17f42c492fd5732e4416b37433b2de20a615f974 /meta-networking
parent58a6f21a54b01386f607b3d3bf86c71186f3b9ef (diff)
downloadmeta-openembedded-contrib-f122ecd7171b2258452131cc75d809b02a1f4f02.tar.gz
arptables: Fix do_install task
We need to run oe_runmake install with DESTDIR variable to install all arptables files. Without this the only file installed in package is systemd unit. Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/arptables/arptables_git.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-networking/recipes-support/arptables/arptables_git.bb b/meta-networking/recipes-support/arptables/arptables_git.bb
index 274a55d91d..cec1d1f77e 100644
--- a/meta-networking/recipes-support/arptables/arptables_git.bb
+++ b/meta-networking/recipes-support/arptables/arptables_git.bb
@@ -23,7 +23,8 @@ inherit systemd
EXTRA_OEMAKE = "'BINDIR=${sbindir}' 'MANDIR=${mandir}'"
-do_install_append() {
+do_install() {
+ oe_runmake install DESTDIR=${D}
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
install -d ${D}${systemd_unitdir}/system
install -m 644 ${WORKDIR}/arptables.service ${D}${systemd_unitdir}/system