aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorS. Lockwood-Childs <sjl@vctlabs.com>2017-12-15 17:18:26 -0800
committerJoe MacDonald <joe_macdonald@mentor.com>2018-01-08 12:05:43 -0500
commit0309df9fb4608590d57f5d358e0723f22a523115 (patch)
tree358e139258391ff95f2f3b7b4780abd3d6d8a338 /meta-networking
parent3b0b5aa94a363d8046c6edac5868174ddd69c2eb (diff)
downloadmeta-openembedded-contrib-0309df9fb4608590d57f5d358e0723f22a523115.tar.gz
cifs-utils: mount.cifs should build without samba dependency
fix following build error when cifsidmap and cifsacl are turned off in PACKAGECONFIG : | In file included from ../git/mount.cifs.c:64:0: | ../git/data_blob.h:26:10: fatal error: talloc.h: No such file or directory cifs-utils 3.7 had an unneeded header creep into mount.cifs source that pulled in samba headers. This has been cleaned up already in cifs-utils master, so apply (trivial) upstream patch to fix this compile error. Signed-off-by: S. Lockwood-Childs <sjl@vctlabs.com> Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/cifs/cifs-utils_git.bb4
-rw-r--r--meta-networking/recipes-support/cifs/files/0001-mount.cifs-Remove-data_blob.h-include.patch32
2 files changed, 35 insertions, 1 deletions
diff --git a/meta-networking/recipes-support/cifs/cifs-utils_git.bb b/meta-networking/recipes-support/cifs/cifs-utils_git.bb
index 3ca5b780bd..198e3ef987 100644
--- a/meta-networking/recipes-support/cifs/cifs-utils_git.bb
+++ b/meta-networking/recipes-support/cifs/cifs-utils_git.bb
@@ -7,7 +7,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
PV = "6.7"
SRCREV = "8101a07871f185c7044fa2ca221b282ab4607c8b"
-SRC_URI = "git://git.samba.org/cifs-utils.git"
+SRC_URI = "git://git.samba.org/cifs-utils.git \
+ file://0001-mount.cifs-Remove-data_blob.h-include.patch \
+ "
S = "${WORKDIR}/git"
DEPENDS += "libtalloc"
diff --git a/meta-networking/recipes-support/cifs/files/0001-mount.cifs-Remove-data_blob.h-include.patch b/meta-networking/recipes-support/cifs/files/0001-mount.cifs-Remove-data_blob.h-include.patch
new file mode 100644
index 0000000000..07f2a57264
--- /dev/null
+++ b/meta-networking/recipes-support/cifs/files/0001-mount.cifs-Remove-data_blob.h-include.patch
@@ -0,0 +1,32 @@
+Upstream-Status: Backport
+Signed-off-by: S. Lockwood-Childs <sjl@vctlabs.com>
+
+From 272d523a57a4e8791d625a479128613be5e401f5 Mon Sep 17 00:00:00 2001
+From: Thomas Witt <pyromaniac@exherbo.org>
+Date: Wed, 15 Mar 2017 20:20:44 +0000
+Subject: [PATCH] mount.cifs: Remove data_blob.h include
+
+data_blob.h includes talloc.h from libtalloc, but that is only marked as
+a dependency for cifs.upcall. No symbols from that header are used by
+cifs.mount, so remove it to avoid the libtalloc dependency
+
+Signed-off-by: Thomas Witt <pyromaniac@exherbo.org>
+---
+ mount.cifs.c | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/mount.cifs.c b/mount.cifs.c
+index 13b71ef..2612feb 100644
+--- a/mount.cifs.c
++++ b/mount.cifs.c
+@@ -61,7 +61,6 @@
+ #include "mount.h"
+ #include "util.h"
+ #include "resolve_host.h"
+-#include "data_blob.h"
+
+ #ifndef MS_MOVE
+ #define MS_MOVE 8192
+--
+1.9.4
+