aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorAndré Draszik <andre.draszik@jci.com>2018-12-05 11:02:32 +0000
committerKhem Raj <raj.khem@gmail.com>2018-12-05 10:18:59 -0800
commite39709e381f4a1229584a3c47e219536a35b78e2 (patch)
treee226186dc7877e3b52cb891913568f17c14e5c95 /meta-networking
parentf87aac8cfea7cf0b65b67661298cea94b9091506 (diff)
downloadmeta-openembedded-contrib-e39709e381f4a1229584a3c47e219536a35b78e2.tar.gz
mosquitto: fix build in systemd environments
The mosquitto systemd service file instructs systemd to wait for mosquitto to notify systemd that mosquitto has started correctly. This isn't working as mosquitto is not *compiled* with systemd support enabled. As such, systemd restarts mosquitto every few seconds. For reference, this was introduced in commit a483d344d9fb ("mosquitto: Make enabling systemd also enable build dep on systemd") Because we build mosquitto using the provided Makefile infrastructure, the solution is to add PACKAGECONFIG_CONFARGS to EXTRA_OEMAKE, so that the required make flags are added to the make command line. Signed-off-by: André Draszik <andre.draszik@jci.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-connectivity/mosquitto/mosquitto_1.5.4.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/mosquitto/mosquitto_1.5.4.bb b/meta-networking/recipes-connectivity/mosquitto/mosquitto_1.5.4.bb
index ee4cab728e..e32f30d6e9 100644
--- a/meta-networking/recipes-connectivity/mosquitto/mosquitto_1.5.4.bb
+++ b/meta-networking/recipes-connectivity/mosquitto/mosquitto_1.5.4.bb
@@ -37,6 +37,7 @@ EXTRA_OEMAKE = " \
${@bb.utils.contains('PACKAGECONFIG', 'ssl', 'WITH_TLS=yes WITH_TLS_PSK=yes', 'WITH_TLS=no WITH_TLS_PSK=no', d)} \
${@bb.utils.contains('PACKAGECONFIG', 'uuid', 'WITH_UUID=yes', 'WITH_UUID=no', d)} \
${@bb.utils.contains('PACKAGECONFIG', 'websockets', 'WITH_WEBSOCKETS=yes', 'WITH_WEBSOCKETS=no', d)} \
+ ${PACKAGECONFIG_CONFARGS} \
STRIP=/bin/true \
WITH_DOCS=no \
WITH_BUNDLED_DEPS=no \