aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authordouglas.royds <douglas.royds@taitradio.com>2018-11-21 13:52:20 +1300
committerKhem Raj <raj.khem@gmail.com>2018-11-26 09:38:14 -0800
commitaf46a5ef3ac0182f7598994f83804f386668c510 (patch)
tree21d2869ccc66d897541cfb0ecda4f5585a9021b5 /meta-networking
parentdcdb5fa30285e156cc7eeecda57f3763ead80c43 (diff)
downloadmeta-openembedded-contrib-af46a5ef3ac0182f7598994f83804f386668c510.tar.gz
net-snmp: Simplify sed expressions
Readability. The existing patterns allowed each pattern to be matched multiple times (with no intevening spaces), but the "g" modifier achieves this anyway. Signed-off-by: Douglas Royds <douglas.royds@taitradio.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-protocols/net-snmp/net-snmp_5.8.bb12
1 files changed, 6 insertions, 6 deletions
diff --git a/meta-networking/recipes-protocols/net-snmp/net-snmp_5.8.bb b/meta-networking/recipes-protocols/net-snmp/net-snmp_5.8.bb
index 2a0d88ab21..7794f3880a 100644
--- a/meta-networking/recipes-protocols/net-snmp/net-snmp_5.8.bb
+++ b/meta-networking/recipes-protocols/net-snmp/net-snmp_5.8.bb
@@ -119,12 +119,12 @@ do_install_append() {
sed -e "s@^NSC_SRCDIR=.*@NSC_SRCDIR=.@g" \
-i ${D}${bindir}/net-snmp-create-v3-user
sed -e 's@^NSC_SRCDIR=.*@NSC_SRCDIR=.@g' \
- -e 's@\([^ ]*-fdebug-prefix-map=[^ "]*\)\1*@@g' \
- -e 's@\([^ ]*--sysroot=[^ "]*\)\1*@@g' \
- -e 's@\([^ ]*--with-libtool-sysroot=[^ "]*\)\1*@@g' \
- -e 's@\([^ ]*--with-install-prefix=[^ "]*\)\1*@@g' \
- -e 's@\([^ ]*PKG_CONFIG_PATH=[^ "]*\)\1*@@g' \
- -e 's@\([^ ]*PKG_CONFIG_LIBDIR=[^ "]*\)\1*@@g' \
+ -e 's@[^ ]*-fdebug-prefix-map=[^ "]*@@g' \
+ -e 's@[^ ]*--sysroot=[^ "]*@@g' \
+ -e 's@[^ ]*--with-libtool-sysroot=[^ "]*@@g' \
+ -e 's@[^ ]*--with-install-prefix=[^ "]*@@g' \
+ -e 's@[^ ]*PKG_CONFIG_PATH=[^ "]*@@g' \
+ -e 's@[^ ]*PKG_CONFIG_LIBDIR=[^ "]*@@g' \
-i ${D}${bindir}/net-snmp-config
if [ "${HAS_PERL}" = "1" ]; then