aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-09-01 14:29:21 -0700
committerKhem Raj <raj.khem@gmail.com>2020-09-01 15:37:44 -0700
commit7df48b8014c32dbfada34163c7856db2abea5e9a (patch)
tree54499ebbb008c16bed4dc2ea54f7ddfef8e64733 /meta-networking/recipes-support
parent0b15dce76afdf132b7bf27e4ea53aeda6ee38cb9 (diff)
downloadmeta-openembedded-contrib-7df48b8014c32dbfada34163c7856db2abea5e9a.tar.gz
quagga,pimd: Use update-alternatives for pimd
pimd is provided by both quagga and pimd, prefer quagga over pimd when both are in image Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support')
-rw-r--r--meta-networking/recipes-support/pimd/pimd_2.3.2.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta-networking/recipes-support/pimd/pimd_2.3.2.bb b/meta-networking/recipes-support/pimd/pimd_2.3.2.bb
index 2faa7cb1ce..df9e85d7de 100644
--- a/meta-networking/recipes-support/pimd/pimd_2.3.2.bb
+++ b/meta-networking/recipes-support/pimd/pimd_2.3.2.bb
@@ -12,9 +12,13 @@ SRC_URI[sha256sum] = "c77a9812751f114490a28a6839b16aac8b020c8d9fd6aa22bf3880c054
EXTRA_OECONF_append_libc-musl = " --embedded-libc"
-inherit autotools-brokensep
+inherit autotools-brokensep update-alternatives
do_configure() {
oe_runconf
}
+ALTERNATIVE_PRIORITY = "100"
+
+ALTERNATIVE_${PN} = "pimd"
+ALTERNATIVE_LINK_NAME[pimd] = "${sbindir}/pimd"