aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support
diff options
context:
space:
mode:
authorClément Péron <peron.clem@gmail.com>2022-02-17 14:16:15 +0100
committerKhem Raj <raj.khem@gmail.com>2022-02-17 14:54:56 -0800
commitf3474b141d57e22c90436974630fc5610d05dd45 (patch)
tree9ea05c5b96afdf3fbd09004f7cfca75bbddba8ee /meta-networking/recipes-support
parent99e2f59d7cfe460d8593bc1b00b2f68ab6c22126 (diff)
downloadmeta-openembedded-contrib-f3474b141d57e22c90436974630fc5610d05dd45.tar.gz
networking: add new netsniff-ng recipe version 0.6.8
Netsniff-ng is a fast zero-copy analyzer, pcap capturing and replaying tool. Actually the Makefile doesn't create the folder when installing tools, let's add a patch to fix this. Signed-off-by: Clément Péron <peron.clem@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support')
-rw-r--r--meta-networking/recipes-support/netsniff-ng/files/0001-Cmds-automatically-create-folder.patch26
-rw-r--r--meta-networking/recipes-support/netsniff-ng/netsniff-ng_0.6.8.bb36
2 files changed, 62 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/netsniff-ng/files/0001-Cmds-automatically-create-folder.patch b/meta-networking/recipes-support/netsniff-ng/files/0001-Cmds-automatically-create-folder.patch
new file mode 100644
index 0000000000..e535aedf51
--- /dev/null
+++ b/meta-networking/recipes-support/netsniff-ng/files/0001-Cmds-automatically-create-folder.patch
@@ -0,0 +1,26 @@
+From 7c00d75d16da18a9998fc4cca28d3c953dd54ceb Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Cl=C3=A9ment=20P=C3=A9ron?= <peron.clem@gmail.com>
+Date: Mon, 14 Feb 2022 18:37:22 +0100
+Subject: [PATCH] Cmds: automatically create folder
+
+---
+ Cmds | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/Cmds b/Cmds
+index e590b38..3df23b8 100644
+--- a/Cmds
++++ b/Cmds
+@@ -44,7 +44,8 @@ ifeq ("$(origin PREFIX)", "$(filter $(origin PREFIX), file command line)")
+ INSTX = echo -e " INST\t$(1)" && install -d $(2) && \
+ install -C $(1) $(2)/$(shell basename $(1))
+ else
+- INSTX = echo -e " INST\t$(1)" && install -C $(1) $(2)/$(shell basename $(1))
++ INSTX = echo -e " INST\t$(1)" && install -d $(2) && \
++ install -C $(1) $(2)/$(shell basename $(1))
+ endif
+
+ MKDIR = echo -e " MKDIR\t$(1)" && mkdir -p $(1)
+--
+2.32.0
+
diff --git a/meta-networking/recipes-support/netsniff-ng/netsniff-ng_0.6.8.bb b/meta-networking/recipes-support/netsniff-ng/netsniff-ng_0.6.8.bb
new file mode 100644
index 0000000000..10e30044e8
--- /dev/null
+++ b/meta-networking/recipes-support/netsniff-ng/netsniff-ng_0.6.8.bb
@@ -0,0 +1,36 @@
+DESCRIPTION = "Netsniff-ng is a fast zero-copy analyzer, pcap capturing and replaying tool"
+HOMEPAGE = "http://netsniff-ng.org"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=9dd40dfb621eed702c0775577fbb7011"
+DEPENDS = "libpcap"
+
+SRCREV = "be3e706f00295024ebc199e70177343fdaebbc9e"
+SRC_URI = " \
+ git://github.com/netsniff-ng/netsniff-ng.git;protocol=https;branch=master \
+ file://0001-Cmds-automatically-create-folder.patch \
+ "
+
+S = "${WORKDIR}/git"
+
+inherit pkgconfig
+
+EXTRA_OEMAKE += " TERM='' "
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[zlib] = ",--disable-zlib,zlib,"
+PACKAGECONFIG[libnl] = ",--disable-libnl,libnl,"
+PACKAGECONFIG[geoip] = ",--disable-geoip,geoip,"
+
+do_configure() {
+ ./configure --prefix=${prefix}
+}
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ oe_runmake DESTDIR=${D} netsniff-ng_install
+}
+
+BBCLASSEXTEND = "native nativesdk"