aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2021-02-05 01:52:13 -0800
committerKhem Raj <raj.khem@gmail.com>2021-02-05 10:59:49 -0800
commitbf527522e019346fcd92bb5d9d5c1906147e24f3 (patch)
tree41b980fe92101de6b46899d3d1c7323f55915088 /meta-networking/recipes-support
parentc105afd3220203fffe78c780b8d7fe2296562852 (diff)
downloadmeta-openembedded-contrib-bf527522e019346fcd92bb5d9d5c1906147e24f3.tar.gz
spice: make conpatible to autoconf-2.70
In order to build with autoconf 2.7, explicitly link to jpeg lib since lib jpeg is already in DEPENDS ... | checking for jpeglib.h... ../git/configure: line 16008: CPP: command not found ... Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support')
-rw-r--r--meta-networking/recipes-support/spice/spice/0001-configure.ac-explicitly-link-to-jpeg-lib.patch48
-rw-r--r--meta-networking/recipes-support/spice/spice_git.bb1
2 files changed, 49 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/spice/spice/0001-configure.ac-explicitly-link-to-jpeg-lib.patch b/meta-networking/recipes-support/spice/spice/0001-configure.ac-explicitly-link-to-jpeg-lib.patch
new file mode 100644
index 0000000000..2d05143dbf
--- /dev/null
+++ b/meta-networking/recipes-support/spice/spice/0001-configure.ac-explicitly-link-to-jpeg-lib.patch
@@ -0,0 +1,48 @@
+From 6ffd9db8e02e411bda2f421abf7951dab6cf0e38 Mon Sep 17 00:00:00 2001
+From: Hongxu Jia <hongxu.jia@windriver.com>
+Date: Fri, 5 Feb 2021 01:43:44 -0800
+Subject: [PATCH] configure.ac: explicitly link to jpeg lib
+
+Since oe has added lib jpeg to the depends, explicitly link to jpeg lib
+to workaround build failure with autoconf 2.7
+
+Upstream-Status: Inappropriate [oe specific]
+
+Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
+---
+ configure.ac | 14 +-------------
+ 1 file changed, 1 insertion(+), 13 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 1ce81f91..8bbb50de 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -191,24 +191,12 @@ AC_SUBST(SSL_CFLAGS)
+ AC_SUBST(SSL_LIBS)
+ AS_VAR_APPEND([SPICE_REQUIRES], [" openssl"])
+
+-AC_CHECK_LIB(jpeg, jpeg_destroy_decompress,
+- AC_MSG_CHECKING([for jpeglib.h])
+- AC_TRY_CPP(
+-[#include <stdio.h>
+-#undef PACKAGE
+-#undef VERSION
+-#undef HAVE_STDLIB_H
+-#include <jpeglib.h>],
+- JPEG_LIBS='-ljpeg'
+- AC_MSG_RESULT($jpeg_ok),
+- AC_MSG_ERROR([jpeglib.h not found])),
+- AC_MSG_ERROR([libjpeg not found]))
++JPEG_LIBS='-ljpeg'
+ AC_SUBST(JPEG_LIBS)
+
+ AC_CHECK_LIB(z, deflate, Z_LIBS='-lz', AC_MSG_ERROR([zlib not found]))
+ AC_SUBST(Z_LIBS)
+
+-
+ AC_ARG_ENABLE([manual],
+ AS_HELP_STRING([--enable-manual=@<:@auto/yes/no@:>@],
+ [Build SPICE manual]),
+--
+2.29.2
+
diff --git a/meta-networking/recipes-support/spice/spice_git.bb b/meta-networking/recipes-support/spice/spice_git.bb
index fad8b639e6..52dad71242 100644
--- a/meta-networking/recipes-support/spice/spice_git.bb
+++ b/meta-networking/recipes-support/spice/spice_git.bb
@@ -25,6 +25,7 @@ SRC_URI = " \
git://anongit.freedesktop.org/spice/spice-common;destsuffix=git/subprojects/spice-common;name=spice-common \
file://0001-Convert-pthread_t-to-be-numeric.patch \
file://0001-Fix-compile-errors-on-Linux-32bit-system.patch \
+ file://0001-configure.ac-explicitly-link-to-jpeg-lib.patch \
"
S = "${WORKDIR}/git"