aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2013-10-31 14:29:45 +0800
committerJoe MacDonald <joe@deserted.net>2013-10-31 13:00:48 -0400
commitedd499dfdba1a944497185af67e307d5cef7ab9e (patch)
treea849d3b989b54666ba47e938fbd34430abf23157 /meta-networking/recipes-support
parent7f1b4775ef198d86821997632bf6e38305f3fa1b (diff)
downloadmeta-openembedded-contrib-edd499dfdba1a944497185af67e307d5cef7ab9e.tar.gz
ndisc6: chmod in do_install and remove unnecessary pkg_postinst
We can use chmod to set the SUID bit for applications in the do_install task. If we do so, the pkg_postinsts are no longer needed. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Joe MacDonald <joe@deserted.net>
Diffstat (limited to 'meta-networking/recipes-support')
-rw-r--r--meta-networking/recipes-support/ndisc6/ndisc6_1.0.2.bb14
1 files changed, 4 insertions, 10 deletions
diff --git a/meta-networking/recipes-support/ndisc6/ndisc6_1.0.2.bb b/meta-networking/recipes-support/ndisc6/ndisc6_1.0.2.bb
index d753912133..a958e37bc5 100644
--- a/meta-networking/recipes-support/ndisc6/ndisc6_1.0.2.bb
+++ b/meta-networking/recipes-support/ndisc6/ndisc6_1.0.2.bb
@@ -49,14 +49,8 @@ servers through slateless IPv6 autoconfiguration."
do_install_append () {
rm -rf ${D}${localstatedir}
-}
-# Enable SUID bit for applications that need it
-pkg_postinst_${PN}-rltraceroute6 () {
- chmod 4555 ${bindir}/rltraceroute6
-}
-pkg_postinst_${PN}-ndisc6 () {
- chmod 4555 ${bindir}/ndisc6
-}
-pkg_postinst_${PN}-rdisc6 () {
- chmod 4555 ${bindir}/rdisc6
+ # Enable SUID bit for applications that need it
+ chmod 4555 ${D}${bindir}/rltraceroute6
+ chmod 4555 ${D}${bindir}/ndisc6
+ chmod 4555 ${D}${bindir}/rdisc6
}