aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support
diff options
context:
space:
mode:
authorYao Zhao <yao.zhao@windriver.com>2014-08-01 10:38:06 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2017-08-31 15:23:00 +0200
commit406e197e675778294793f9c9accd3cd202fdffc4 (patch)
treef0ec28dadb98ae4f08fb3279207455b8baca5af9 /meta-networking/recipes-support
parentb006538f391d38c1764ecf1130cc7362c62adb07 (diff)
downloadmeta-openembedded-contrib-406e197e675778294793f9c9accd3cd202fdffc4.tar.gz
add support for opendataplane
The OpenDataPlane (ODP) project provides a data plane application programming environment that is easy to use, high performance, and portable between networking SoCs. support build opendataplane release 0.2 and current HEAD from linaro. For dpdk build, it is tested against layer meta-intel's common/recipes-extended/dpdk/dpdk_1.6.0r2.bb recipe. And it is needed to change its do_configure to add support for a single intel_dpdk library.(default is multiple static libraries) for example: @@ -35,6 +35,8 @@ do_configure () { ############################################################# unset prefix + sed -i -e "s/CONFIG_RTE_BUILD_COMBINE_LIBS=n/CONFIG_RTE_BUILD_COMBINE_LIBS=y/g" \ + config/defconfig_${TARGET_ARCH}-default-${TARGET_OS}app-gcc make O=$RTE_TARGET T=$RTE_TARGET config Signed-off-by: Yao Zhao <yao.zhao@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support')
-rw-r--r--meta-networking/recipes-support/opendataplane/files/0001-linux-dpdk-remove-unnecessary-include-path.patch29
-rw-r--r--meta-networking/recipes-support/opendataplane/opendataplane.inc21
-rw-r--r--meta-networking/recipes-support/opendataplane/opendataplane_0.2.bb25
-rw-r--r--meta-networking/recipes-support/opendataplane/opendataplane_git.bb14
4 files changed, 89 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/opendataplane/files/0001-linux-dpdk-remove-unnecessary-include-path.patch b/meta-networking/recipes-support/opendataplane/files/0001-linux-dpdk-remove-unnecessary-include-path.patch
new file mode 100644
index 0000000000..a0ef7ced81
--- /dev/null
+++ b/meta-networking/recipes-support/opendataplane/files/0001-linux-dpdk-remove-unnecessary-include-path.patch
@@ -0,0 +1,29 @@
+From 72b8eacc2985f054cadc5d0b48351a658998b8d6 Mon Sep 17 00:00:00 2001
+From: Yao Zhao <yao.zhao@windriver.com>
+Date: Wed, 30 Jul 2014 16:02:14 -0400
+Subject: [PATCH] linux-dpdk: remove unnecessary include path
+
+for dpdk include/arch and include/exec-env is only included
+by generic rte_xxx.h header, can't be included directly.
+
+Signed-off-by: Yao Zhao <yao.zhao@windriver.com>
+---
+ platform/linux-dpdk/Makefile.am | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/platform/linux-dpdk/Makefile.am b/platform/linux-dpdk/Makefile.am
+index 4aa568f..dfcaadb 100644
+--- a/platform/linux-dpdk/Makefile.am
++++ b/platform/linux-dpdk/Makefile.am
+@@ -12,8 +12,6 @@ PLAT_CFLAGS = -msse4.2
+ if SDK_INSTALL_PATH_
+ PLAT_CFLAGS += -include $(SDK_INSTALL_PATH)/include/rte_config.h
+ PLAT_CFLAGS += -I$(SDK_INSTALL_PATH)/include
+-PLAT_CFLAGS += -I$(SDK_INSTALL_PATH)/include/arch
+-PLAT_CFLAGS += -I$(SDK_INSTALL_PATH)/include/exec-env
+
+ AM_LDFLAGS += -L$(SDK_INSTALL_PATH)/lib
+ endif
+--
+1.9.1
+
diff --git a/meta-networking/recipes-support/opendataplane/opendataplane.inc b/meta-networking/recipes-support/opendataplane/opendataplane.inc
new file mode 100644
index 0000000000..c4b184e20d
--- /dev/null
+++ b/meta-networking/recipes-support/opendataplane/opendataplane.inc
@@ -0,0 +1,21 @@
+SUMMARY = "Cross platform OpenDataPlane application APIs"
+
+DESCRIPTION = "The OpenDataPlane project has been established to \
+produce an open-source, cross-platform set of application \
+programming interfaces (APIs) for the networking data plane."
+
+HOMEPAGE = "http://www.opendataplane.org"
+SECTION = "networking"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4ccfa994aa96974cfcd39a59faee20a2"
+
+SRC_URI = "git://git.linaro.org/lng/odp.git"
+
+COMPATIBLE_HOST = "^((?!mips).*)$"
+
+PACKAGECONFIG ??= "platform_linux_generic"
+PACKAGECONFIG[netmap] = "--enable-netmap,,,"
+PACKAGECONFIG[platform_linux_generic] = "--with-platform=linux-generic,,,"
+
+S = "${WORKDIR}/git"
+
diff --git a/meta-networking/recipes-support/opendataplane/opendataplane_0.2.bb b/meta-networking/recipes-support/opendataplane/opendataplane_0.2.bb
new file mode 100644
index 0000000000..6f7f601b10
--- /dev/null
+++ b/meta-networking/recipes-support/opendataplane/opendataplane_0.2.bb
@@ -0,0 +1,25 @@
+require ${BPN}.inc
+
+#odp-0.2 tag
+SRCREV = "6007d8833a6880abedf98f792586c0cfb9f10de0"
+PV = "0.2"
+
+#0.2 still using pure Makefile
+
+#override the Makefile DESTDIR
+export DESTDIR="${D}${exec_prefix}"
+
+do_install () {
+ oe_runmake install
+
+ #move DESTDIR/share/odp/odp_x usr/bin
+ install -d ${D}${bindir}
+ for i in ${DESTDIR}/share/odp/*; do
+ filename=`basename $i`
+ mv ${DESTDIR}/share/odp/${filename} ${D}${bindir}/${filename}
+ done
+ rm -rf ${DESTDIR}/share
+}
+
+#non standard doc install location
+FILES_${PN}-doc += "${exec_prefix}/doc/*"
diff --git a/meta-networking/recipes-support/opendataplane/opendataplane_git.bb b/meta-networking/recipes-support/opendataplane/opendataplane_git.bb
new file mode 100644
index 0000000000..e569daad00
--- /dev/null
+++ b/meta-networking/recipes-support/opendataplane/opendataplane_git.bb
@@ -0,0 +1,14 @@
+require ${BPN}.inc
+
+SRC_URI += "file://0001-linux-dpdk-remove-unnecessary-include-path.patch"
+
+SRCREV = "68a45b11e52dbf835a7087c15d503c6b0e5d91ed"
+#8f4f080625e2db810da3f13770ba418c72b08ede will support --with-sdk-install-path
+PV = "0.2+git${SRCPV}"
+
+PACKAGECONFIG[platform_linux_generic] = "--with-platform=linux-generic,,openssl,libcrypto"
+#need meta-intel layer's common/recipes-extended/dpdk/dpdk recipe
+PACKAGECONFIG[platform_linux_dpdk] = '--with-platform=linux-dpdk --with-sdk-install-path="${STAGING_EXECPREFIXDIR}",,dpdk,'
+PACKAGECONFIG[platform_linux_keystone2] = "--with-platform=linux-keystone2,,,"
+
+inherit autotools