aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-05-20 17:56:07 -0700
committerKhem Raj <raj.khem@gmail.com>2024-05-23 08:44:42 -0700
commit673ba54e98c85ee1ff421a782b1b489c60b53803 (patch)
treed9384955f6986e36e9f90245201e1833c2c271b9 /meta-networking/recipes-support
parent7b02f14be9cd394778f5c52f2519a85afe6d553f (diff)
downloadmeta-openembedded-contrib-673ba54e98c85ee1ff421a782b1b489c60b53803.tar.gz
nbd: Fix build with GCC14 on musl targets
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support')
-rw-r--r--meta-networking/recipes-support/nbd/nbd/0001-nbd-client-Fix-build-on-musl-gcc14.patch43
-rw-r--r--meta-networking/recipes-support/nbd/nbd_3.26.1.bb4
2 files changed, 46 insertions, 1 deletions
diff --git a/meta-networking/recipes-support/nbd/nbd/0001-nbd-client-Fix-build-on-musl-gcc14.patch b/meta-networking/recipes-support/nbd/nbd/0001-nbd-client-Fix-build-on-musl-gcc14.patch
new file mode 100644
index 0000000000..15b439e255
--- /dev/null
+++ b/meta-networking/recipes-support/nbd/nbd/0001-nbd-client-Fix-build-on-musl-gcc14.patch
@@ -0,0 +1,43 @@
+From 909d20a2ee4afecd5ae4cc5950c8ee599f72972d Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Mon, 20 May 2024 17:48:13 -0700
+Subject: [PATCH] nbd-client: Fix build on musl + gcc14
+
+GCC-14 has promoted incompatible-pointer-types warning into error which is
+now flagged especially with when building on musl
+
+Fixes following error
+
+| ../nbd-3.26.1/nbd-client.c: In function 'openunix':
+| ../nbd-3.26.1/nbd-client.c:345:27: error: passing argument 2 of 'connect' from incompatible pointer type [-Wincompatible-pointer-types]
+| 345 | if (connect(sock, &un_addr, sizeof(un_addr)) == -1) {
+| | ^~~~~~~~
+| | |
+| | struct sockaddr_un *
+| In file included from ../nbd-3.26.1/nbd-client.c:25:
+| /mnt/b/yoe/master/build/tmp/work/core2-64-yoe-linux-musl/nbd/3.26.1/recipe-sysroot/usr/include/sys/socket.h:386:19: note: expected 'const struct sockaddr *' but argument is of type 'struct sockaddr_un *'
+| 386 | int connect (int, const struct sockaddr *, socklen_t);
+| | ^~~~~~~~~~~~~~~~~~~~~~~
+
+Upstream-Status: Submitted [https://lists.debian.org/nbd/2024/05/msg00012.html]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ nbd-client.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/nbd-client.c b/nbd-client.c
+index 8d1101b..7b25c67 100644
+--- a/nbd-client.c
++++ b/nbd-client.c
+@@ -342,7 +342,7 @@ int openunix(const char *path) {
+ return -1;
+ };
+
+- if (connect(sock, &un_addr, sizeof(un_addr)) == -1) {
++ if (connect(sock, (struct sockaddr*)&un_addr, sizeof(un_addr)) == -1) {
+ err_nonfatal("CONNECT failed");
+ close(sock);
+ return -1;
+--
+2.45.1
+
diff --git a/meta-networking/recipes-support/nbd/nbd_3.26.1.bb b/meta-networking/recipes-support/nbd/nbd_3.26.1.bb
index 15d5f8b36b..a67b087f74 100644
--- a/meta-networking/recipes-support/nbd/nbd_3.26.1.bb
+++ b/meta-networking/recipes-support/nbd/nbd_3.26.1.bb
@@ -7,7 +7,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
DEPENDS = "autoconf-archive bison-native glib-2.0 libnl zlib bison-native"
SRC_URI = "https://github.com/NetworkBlockDevice/${BPN}/releases/download/${BP}/${BP}.tar.xz \
- file://f0418b0d8b54c21a1e5b0c6dce3277e938d07e7c.patch"
+ file://f0418b0d8b54c21a1e5b0c6dce3277e938d07e7c.patch \
+ file://0001-nbd-client-Fix-build-on-musl-gcc14.patch \
+ "
SRC_URI[sha256sum] = "f0cf509fa5b20b1a07f7904eb637e9b47d3e30b6ed6f00075af5d8b701c78fef"
inherit autotools pkgconfig systemd