aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/wireshark
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-07-29 17:04:53 +0200
committerKhem Raj <raj.khem@gmail.com>2021-08-03 10:21:25 -0700
commitc61dc077bbd81260e4f167fa2251643ba0ba6974 (patch)
tree66c3243f8f64ae60f66f70a16e8128c247254a65 /meta-networking/recipes-support/wireshark
parentc5f7cfb8db54cfa4257797db5bd87828dea43296 (diff)
downloadmeta-openembedded-contrib-c61dc077bbd81260e4f167fa2251643ba0ba6974.tar.gz
Convert to new override syntax
This is the result of automated script (0.9.1) conversion: oe-core/scripts/contrib/convert-overrides.py . converting the metadata to use ":" as the override character instead of "_". Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support/wireshark')
-rw-r--r--meta-networking/recipes-support/wireshark/README4
-rw-r--r--meta-networking/recipes-support/wireshark/wireshark_3.4.7.bb16
2 files changed, 10 insertions, 10 deletions
diff --git a/meta-networking/recipes-support/wireshark/README b/meta-networking/recipes-support/wireshark/README
index 63b5b72631..f5e4d04777 100644
--- a/meta-networking/recipes-support/wireshark/README
+++ b/meta-networking/recipes-support/wireshark/README
@@ -14,12 +14,12 @@ Adding the wireshark to your build
========================================
via local.conf
-IMAGE_INSTALL_append = " wireshark"
+IMAGE_INSTALL:append = " wireshark"
Adding the wireshark to your graphical build
========================================
via local.conf
-IMAGE_INSTALL_append = " wireshark"
+IMAGE_INSTALL:append = " wireshark"
and one of:
diff --git a/meta-networking/recipes-support/wireshark/wireshark_3.4.7.bb b/meta-networking/recipes-support/wireshark/wireshark_3.4.7.bb
index 7bc5a8150c..fc360f6691 100644
--- a/meta-networking/recipes-support/wireshark/wireshark_3.4.7.bb
+++ b/meta-networking/recipes-support/wireshark/wireshark_3.4.7.bb
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=6e271234ba1a13c6e512e76b94ac2f77"
DEPENDS = "pcre expat glib-2.0 glib-2.0-native libgcrypt libgpg-error libxml2 bison-native c-ares"
-DEPENDS_append_class-target = " wireshark-native chrpath-replacement-native "
+DEPENDS:append:class-target = " wireshark-native chrpath-replacement-native "
SRC_URI = "https://1.eu.dl.wireshark.org/src/all-versions/wireshark-${PV}.tar.xz"
@@ -27,7 +27,7 @@ inherit cmake pkgconfig python3native perlnative upstream-version-is-even mime m
PACKAGECONFIG ?= "libpcap gnutls libnl libcap sbc"
-PACKAGECONFIG_class-native = "libpcap gnutls ssl libssh"
+PACKAGECONFIG:class-native = "libpcap gnutls ssl libssh"
PACKAGECONFIG[libcap] = "-DENABLE_CAP=ON,-DENABLE_CAP=OFF -DENABLE_PCAP_NG_DEFAULT=ON, libcap"
PACKAGECONFIG[libpcap] = "-DENABLE_PCAP=ON,-DENABLE_PCAP=OFF -DENABLE_PCAP_NG_DEFAULT=ON , libpcap"
@@ -60,9 +60,9 @@ EXTRA_OECMAKE += "-DENABLE_NETLINK=ON \
-DM_INCLUDE_DIR=${includedir} \
-DM_LIBRARY=${libdir} \
"
-CFLAGS_append = " -lm"
+CFLAGS:append = " -lm"
-do_install_append_class-native() {
+do_install:append:class-native() {
install -d ${D}${bindir}
for f in lemon
do
@@ -70,7 +70,7 @@ do_install_append_class-native() {
done
}
-do_install_append_class-target() {
+do_install:append:class-target() {
for f in `find ${D}${libdir} ${D}${bindir} -type f -executable`
do
chrpath --delete $f
@@ -79,10 +79,10 @@ do_install_append_class-target() {
PACKAGE_BEFORE_PN += "tshark"
-FILES_tshark = "${bindir}/tshark ${mandir}/man1/tshark.*"
+FILES:tshark = "${bindir}/tshark ${mandir}/man1/tshark.*"
-FILES_${PN} += "${datadir}*"
+FILES:${PN} += "${datadir}*"
-RDEPENDS_tshark = "wireshark"
+RDEPENDS:tshark = "wireshark"
BBCLASSEXTEND = "native"