aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/tunctl/tunctl
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2016-11-01 17:23:05 +0800
committerJoe MacDonald <joe_macdonald@mentor.com>2016-11-14 13:01:11 -0500
commit294d7126ff5a6a079595a56513b789619de5944d (patch)
tree7af84b2e6b44a4e2b3955ab74b0b96c8bbd67f19 /meta-networking/recipes-support/tunctl/tunctl
parentf08e9d4c7ca1e9261484e4ffedd27370109d2bba (diff)
downloadmeta-openembedded-contrib-294d7126ff5a6a079595a56513b789619de5944d.tar.gz
tunctl: fix QA warning for GNU_HASH
Add LDFLAGS variable to Makefile so that extra linker flags can be sent via this variable. Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support/tunctl/tunctl')
-rw-r--r--meta-networking/recipes-support/tunctl/tunctl/makefile-add-ldflags.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/tunctl/tunctl/makefile-add-ldflags.patch b/meta-networking/recipes-support/tunctl/tunctl/makefile-add-ldflags.patch
new file mode 100644
index 0000000000..c96f538d2d
--- /dev/null
+++ b/meta-networking/recipes-support/tunctl/tunctl/makefile-add-ldflags.patch
@@ -0,0 +1,19 @@
+Add LDFLAGS variable to Makefile, make sure the extra linker flags can be passed.
+
+Upstream-Status: Pending
+
+Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
+
+diff --git a/Makefile b/Makefile
+index a0aa7f6..d6ce2c7 100644
+--- a/Makefile
++++ b/Makefile
+@@ -14,7 +14,7 @@ MAN_DIR ?= /usr/share/man/man$(MANS)
+ all : $(BIN) $(MAN)
+
+ $(BIN) : $(BIN).c
+- $(CC) $(CFLAGS) -o $(BIN) $(BIN).c
++ $(CC) $(CFLAGS) ${LDFLAGS} -o $(BIN) $(BIN).c
+
+ $(MAN) : $(PACKAGE).sgml
+ docbook2man $(PACKAGE).sgml