aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/strongswan
diff options
context:
space:
mode:
authorCallaghan, Dan <dan.callaghan@opengear.com>2019-10-15 09:39:09 +1000
committerKhem Raj <raj.khem@gmail.com>2019-10-17 05:53:25 -0700
commit699cd1602ee0e6c2791b15cfe06705e325c98b53 (patch)
treebe57bc87c5d418db4605e21f80c747969b628993 /meta-networking/recipes-support/strongswan
parent3b18a93727f5a4fb201e55ffaa253adda72a68d6 (diff)
downloadmeta-openembedded-contrib-699cd1602ee0e6c2791b15cfe06705e325c98b53.tar.gz
strongswan: add a PACKAGECONFIG for libbfd stack traces
Strongswan installs a signal handler for SIGSEGV, SIGILL, and SIGBUS which attempts to print a stack trace of the crash. For producing line numbers in the stack trace, it can use libbfd from binutils, or libunwind, or else it falls back to a slower method using /usr/bin/addr2line. Currently the addr2line method is unlikely to actually work, since there is no RDEPENDS to pull that command into the image. This patch adds a PACKAGECONFIG to enable the libbfd-based stack traces, which is likely the best alternative since binutils is already required for building everything, and it will be faster than the addr2line method (which requires addr2line and libbfd anyway). Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support/strongswan')
-rw-r--r--meta-networking/recipes-support/strongswan/strongswan_5.8.1.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/strongswan/strongswan_5.8.1.bb b/meta-networking/recipes-support/strongswan/strongswan_5.8.1.bb
index 5408eed275..b521633ff4 100644
--- a/meta-networking/recipes-support/strongswan/strongswan_5.8.1.bb
+++ b/meta-networking/recipes-support/strongswan/strongswan_5.8.1.bb
@@ -28,6 +28,7 @@ PACKAGECONFIG ??= "charon curl gmp openssl stroke sqlite3 \
${@bb.utils.filter('DISTRO_FEATURES', 'ldap', d)} \
"
PACKAGECONFIG[aesni] = "--enable-aesni,--disable-aesni,,${PN}-plugin-aesni"
+PACKAGECONFIG[bfd] = "--enable-bfd-backtraces,--disable-bfd-backtraces,binutils"
PACKAGECONFIG[charon] = "--enable-charon,--disable-charon,"
PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl,${PN}-plugin-curl"
PACKAGECONFIG[gmp] = "--enable-gmp,--disable-gmp,gmp,${PN}-plugin-gmp"