aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/strongswan
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-04-22 20:48:50 +0100
committerJoe MacDonald <joe_macdonald@mentor.com>2016-05-05 11:41:28 -0400
commit275b6c30fbe4f2e6d8c607e9f2eedd5c230c0802 (patch)
tree4fd20a242b848ec8497066801b86706de3defdce /meta-networking/recipes-support/strongswan
parent7a9c626092c7d3b10206c7ca4ea2827cca9cba4f (diff)
downloadmeta-openembedded-contrib-275b6c30fbe4f2e6d8c607e9f2eedd5c230c0802.tar.gz
meta-networking: use bb.utils.contains() instead of base_contains()
base_contains() is a compatibility wrapper and may warn in the future, so replace all instances with bb.utils.contains(). Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support/strongswan')
-rw-r--r--meta-networking/recipes-support/strongswan/strongswan_5.3.2.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-networking/recipes-support/strongswan/strongswan_5.3.2.bb b/meta-networking/recipes-support/strongswan/strongswan_5.3.2.bb
index 7ec1a8ee17..9dc4878c67 100644
--- a/meta-networking/recipes-support/strongswan/strongswan_5.3.2.bb
+++ b/meta-networking/recipes-support/strongswan/strongswan_5.3.2.bb
@@ -20,11 +20,11 @@ EXTRA_OECONF = " \
--without-lib-prefix \
"
-EXTRA_OECONF += "${@base_contains('DISTRO_FEATURES', 'systemd', '--with-systemdsystemunitdir=${systemd_unitdir}/system/', '--without-systemdsystemunitdir', d)}"
+EXTRA_OECONF += "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '--with-systemdsystemunitdir=${systemd_unitdir}/system/', '--without-systemdsystemunitdir', d)}"
PACKAGECONFIG ??= "charon curl gmp openssl stroke sqlite3 \
- ${@base_contains('DISTRO_FEATURES', 'ldap', 'ldap', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'ldap', 'ldap', '', d)} \
"
PACKAGECONFIG[aesni] = "--enable-aesni,--disable-aesni,"
PACKAGECONFIG[charon] = "--enable-charon,--disable-charon,"