aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/ruli/ruli_0.36.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-11-20 11:42:40 -0800
committerArmin Kuster <akuster808@gmail.com>2020-01-05 14:44:11 -0800
commite855ecc6d35677e79780adc57b2552213c995731 (patch)
tree07bcea17ac0a92706f3260ed32f3cefee7b609ea /meta-networking/recipes-support/ruli/ruli_0.36.bb
parent86b4e31912709c7891f093b3bbbcecbc9cc81838 (diff)
downloadmeta-openembedded-contrib-e855ecc6d35677e79780adc57b2552213c995731.tar.gz
ruli: Fix install step and build samples too
do_install never executed as a result it was empty install Create ruli-bin package for utilities, so libraries can be packages granularily Drop the makefile patch which is no longer needed, set the make variables to get the needed bits set Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit f4e6224b340fba198639bdd4585a81efdf15303e) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support/ruli/ruli_0.36.bb')
-rw-r--r--meta-networking/recipes-support/ruli/ruli_0.36.bb23
1 files changed, 16 insertions, 7 deletions
diff --git a/meta-networking/recipes-support/ruli/ruli_0.36.bb b/meta-networking/recipes-support/ruli/ruli_0.36.bb
index 885796d2a5..b82a3d08e8 100644
--- a/meta-networking/recipes-support/ruli/ruli_0.36.bb
+++ b/meta-networking/recipes-support/ruli/ruli_0.36.bb
@@ -8,18 +8,27 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
DEPENDS = "liboop"
SRC_URI = "http://download.savannah.gnu.org/releases/ruli/ruli_${PV}.orig.tar.gz \
- file://Makefile.patch \
file://0001-Fix-build-with-format-string-checks.patch \
file://0001-src-ruli_addr.c-Add-missing-format-string.patch \
+ file://0001-ruli_srv-Mark-prev_addr_list_size-as-unused.patch \
+ file://0001-Make-space-for-flags-from-environment.patch \
"
SRC_URI[md5sum] = "e73fbfdeadddb68a703a70cea5271468"
SRC_URI[sha256sum] = "11d32def5b514748fbd9ea8c88049ae99e1bb358efc74eb91a4d268a3999dbfa"
-do_install1() {
- install -d ${D}${includedir}/ruli
- install -d ${D}${libdir}
- install -m 0644 ${S}/src/ruli*.h ${D}${includedir}/ruli
- install -m 0644 ${S}/src/libruli.so ${D}${libdir}
- install -m 0644 ${S}/src/libruli.so.4 ${D}${libdir}
+B = "${S}"
+
+EXTRA_OEMAKE = 'CC="${CC}" OOP_BASE_DIR="${STAGING_EXECPREFIXDIR}" INSTALL_BASE_DIR="${D}${exec_prefix}"'
+
+do_configure() {
+ touch configure-stamp
+}
+
+do_install() {
+ oe_runmake install
}
+
+PACKAGES =+ "${PN}-bin"
+
+FILES_${PN} =+ "${bindir}"