aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/opendataplane/opendataplane_git.bb
diff options
context:
space:
mode:
authorYao Zhao <yao.zhao@windriver.com>2014-08-01 10:38:06 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2017-08-31 15:23:00 +0200
commit406e197e675778294793f9c9accd3cd202fdffc4 (patch)
treef0ec28dadb98ae4f08fb3279207455b8baca5af9 /meta-networking/recipes-support/opendataplane/opendataplane_git.bb
parentb006538f391d38c1764ecf1130cc7362c62adb07 (diff)
downloadmeta-openembedded-contrib-406e197e675778294793f9c9accd3cd202fdffc4.tar.gz
add support for opendataplane
The OpenDataPlane (ODP) project provides a data plane application programming environment that is easy to use, high performance, and portable between networking SoCs. support build opendataplane release 0.2 and current HEAD from linaro. For dpdk build, it is tested against layer meta-intel's common/recipes-extended/dpdk/dpdk_1.6.0r2.bb recipe. And it is needed to change its do_configure to add support for a single intel_dpdk library.(default is multiple static libraries) for example: @@ -35,6 +35,8 @@ do_configure () { ############################################################# unset prefix + sed -i -e "s/CONFIG_RTE_BUILD_COMBINE_LIBS=n/CONFIG_RTE_BUILD_COMBINE_LIBS=y/g" \ + config/defconfig_${TARGET_ARCH}-default-${TARGET_OS}app-gcc make O=$RTE_TARGET T=$RTE_TARGET config Signed-off-by: Yao Zhao <yao.zhao@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support/opendataplane/opendataplane_git.bb')
-rw-r--r--meta-networking/recipes-support/opendataplane/opendataplane_git.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/opendataplane/opendataplane_git.bb b/meta-networking/recipes-support/opendataplane/opendataplane_git.bb
new file mode 100644
index 0000000000..e569daad00
--- /dev/null
+++ b/meta-networking/recipes-support/opendataplane/opendataplane_git.bb
@@ -0,0 +1,14 @@
+require ${BPN}.inc
+
+SRC_URI += "file://0001-linux-dpdk-remove-unnecessary-include-path.patch"
+
+SRCREV = "68a45b11e52dbf835a7087c15d503c6b0e5d91ed"
+#8f4f080625e2db810da3f13770ba418c72b08ede will support --with-sdk-install-path
+PV = "0.2+git${SRCPV}"
+
+PACKAGECONFIG[platform_linux_generic] = "--with-platform=linux-generic,,openssl,libcrypto"
+#need meta-intel layer's common/recipes-extended/dpdk/dpdk recipe
+PACKAGECONFIG[platform_linux_dpdk] = '--with-platform=linux-dpdk --with-sdk-install-path="${STAGING_EXECPREFIXDIR}",,dpdk,'
+PACKAGECONFIG[platform_linux_keystone2] = "--with-platform=linux-keystone2,,,"
+
+inherit autotools