aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/ntp/ntp_4.2.6p5.bb
diff options
context:
space:
mode:
authorMorgan Little <morgan.little@windriver.com>2012-10-23 16:20:20 +0000
committerJoe MacDonald <joe.macdonald@windriver.com>2012-10-25 12:16:20 -0400
commitd102fc3fe64844f5c85ff350874728139a63fe78 (patch)
treebd422d1d662fd832b148a7ae0fe067b78a7df574 /meta-networking/recipes-support/ntp/ntp_4.2.6p5.bb
parente15543f05bb2c321cd649b90de50d1a3d8cd1199 (diff)
downloadmeta-openembedded-contrib-d102fc3fe64844f5c85ff350874728139a63fe78.tar.gz
ntp: Clean up recipes
Clean up recipes to make them easier to read and to allow ntp-ssl to build * Move common portions to ntp.inc * Update ntp-ssl to require ntp.inc oppose to ntp_${PV}.bb * Change ntp-ssl EXTRA_OECONF to append so it won't try to configure snmp as it will use local paths can cause a error while configuring Signed-off-by: Morgan Little <morgan.little@windriver.com>
Diffstat (limited to 'meta-networking/recipes-support/ntp/ntp_4.2.6p5.bb')
-rw-r--r--meta-networking/recipes-support/ntp/ntp_4.2.6p5.bb43
1 files changed, 1 insertions, 42 deletions
diff --git a/meta-networking/recipes-support/ntp/ntp_4.2.6p5.bb b/meta-networking/recipes-support/ntp/ntp_4.2.6p5.bb
index f7c5b68856..175a1b07ed 100644
--- a/meta-networking/recipes-support/ntp/ntp_4.2.6p5.bb
+++ b/meta-networking/recipes-support/ntp/ntp_4.2.6p5.bb
@@ -1,45 +1,4 @@
require ntp.inc
-SRC_URI = "http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2/ntp-${PV}.tar.gz \
- file://tickadj.c.patch \
- file://ntp-4.2.4_p6-nano.patch \
- file://ntpd \
- file://ntp.conf \
- file://ntpdate \
-"
-
-SRC_URI[md5sum] = "59876a9009b098ff59767ee45a88ebd2"
-SRC_URI[sha256sum] = "6e84d4ddfa14b911c3ed88463af10867e1fa9b287e7b34d8a02e78be85a7c40e"
-
-EXTRA_OECONF += " --with-net-snmp-config=no --without-ntpsnmpd"
-
-do_install_append() {
- install -d ${D}/${sysconfdir}/init.d
- install -m 644 ${WORKDIR}/ntp.conf ${D}/${sysconfdir}
- install -m 755 ${WORKDIR}/ntpd ${D}/${sysconfdir}/init.d
- install -d ${D}/${sysconfdir}/network/if-up.d
- install -m 755 ${WORKDIR}/ntpdate ${D}/${sysconfdir}/network/if-up.d
-}
-
-FILES_${PN}-bin = "${bindir}/ntp-wait ${bindir}/ntpdc ${bindir}/ntpq ${bindir}/ntptime ${bindir}/ntptrace"
-FILES_${PN} = "${bindir}/ntpd ${sysconfdir}/ntp.conf ${sysconfdir}/init.d/ntpd"
-FILES_${PN}-tickadj = "${bindir}/tickadj"
-FILES_ntp-utils = "${bindir}/*"
-FILES_ntpdate = "${bindir}/ntpdate ${sysconfdir}/network/if-up.d/ntpdate"
-
-# ntp originally includes tickadj. It's split off for inclusion in small firmware images on platforms
-# with wonky clocks (e.g. OpenSlug)
-RDEPENDS_${PN} = "${PN}-tickadj"
-
-pkg_postinst_ntpdate() {
-if test "x$D" != "x"; then
- exit 1
-else
- if ! grep -q -s ntpdate /var/spool/cron/root; then
- echo "adding crontab"
- test -d /var/spool/cron || mkdir -p /var/spool/cron
- echo "30 * * * * /usr/bin/ntpdate -b -s -u pool.ntp.org" >> /var/spool/cron/root
- fi
-fi
-}
+EXTRA_OECONF += "--without-openssl --without-crypto"