aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/ntopng
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-07-29 17:04:53 +0200
committerKhem Raj <raj.khem@gmail.com>2021-08-03 10:21:25 -0700
commitc61dc077bbd81260e4f167fa2251643ba0ba6974 (patch)
tree66c3243f8f64ae60f66f70a16e8128c247254a65 /meta-networking/recipes-support/ntopng
parentc5f7cfb8db54cfa4257797db5bd87828dea43296 (diff)
downloadmeta-openembedded-contrib-c61dc077bbd81260e4f167fa2251643ba0ba6974.tar.gz
Convert to new override syntax
This is the result of automated script (0.9.1) conversion: oe-core/scripts/contrib/convert-overrides.py . converting the metadata to use ":" as the override character instead of "_". Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support/ntopng')
-rw-r--r--meta-networking/recipes-support/ntopng/ndpi_3.4.bb4
-rw-r--r--meta-networking/recipes-support/ntopng/ntopng_4.2.bb18
2 files changed, 11 insertions, 11 deletions
diff --git a/meta-networking/recipes-support/ntopng/ndpi_3.4.bb b/meta-networking/recipes-support/ntopng/ndpi_3.4.bb
index 22e4d8e9ae..cfc60a7aab 100644
--- a/meta-networking/recipes-support/ntopng/ndpi_3.4.bb
+++ b/meta-networking/recipes-support/ntopng/ndpi_3.4.bb
@@ -4,7 +4,7 @@ inspection. Based on OpenDPI it includes ntop extensions"
SECTION = "libdevel"
DEPENDS = "libpcap"
-RDEPENDS_${PN} += " libpcap"
+RDEPENDS:${PN} += " libpcap"
LICENSE = "GPLv3"
LIC_FILES_CHKSUM = "file://COPYING;md5=b52f2d57d10c4f7ee67a7eb9615d5d24"
@@ -19,7 +19,7 @@ inherit autotools-brokensep pkgconfig
CPPFLAGS += "${SELECTED_OPTIMIZATION}"
-do_configure_prepend() {
+do_configure:prepend() {
${S}/autogen.sh
}
diff --git a/meta-networking/recipes-support/ntopng/ntopng_4.2.bb b/meta-networking/recipes-support/ntopng/ntopng_4.2.bb
index 5961866515..cc23207888 100644
--- a/meta-networking/recipes-support/ntopng/ntopng_4.2.bb
+++ b/meta-networking/recipes-support/ntopng/ntopng_4.2.bb
@@ -7,7 +7,7 @@ usability, and features."
SECTION = "console/network"
DEPENDS = "curl libmaxminddb libpcap lua mariadb ndpi json-c rrdtool zeromq"
-RDEPENDS_${PN} = "bash redis"
+RDEPENDS:${PN} = "bash redis"
LICENSE = "GPLv3"
LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
@@ -26,24 +26,24 @@ S = "${WORKDIR}/git"
# don't use the lua under thirdparty as it supports cross compiling badly
export LUA_LIB = "${STAGING_LIBDIR}/liblua.a"
-LDFLAGS_append_mipsarch = " -latomic"
-LDFLAGS_append_powerpc = " -latomic"
-LDFLAGS_append_riscv32 = " -latomic"
+LDFLAGS:append:mipsarch = " -latomic"
+LDFLAGS:append:powerpc = " -latomic"
+LDFLAGS:append:riscv32 = " -latomic"
inherit autotools-brokensep gettext systemd
-do_install_append() {
+do_install:append() {
install -d ${D}${systemd_unitdir}/system/
install -m 0644 ${WORKDIR}/ntopng.service ${D}${systemd_unitdir}/system
}
-FILES_${PN} += "\
+FILES:${PN} += "\
${systemd_unitdir}/system/ntopng.service"
-FILES_${PN}-doc += "\
+FILES:${PN}-doc += "\
/usr/man/man8/ntopng.8"
-do_configure_prepend() {
+do_configure:prepend() {
${S}/autogen.sh
}
-SYSTEMD_SERVICE_${PN} = "ntopng.service"
+SYSTEMD_SERVICE:${PN} = "ntopng.service"