aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/netcat/netcat_0.7.1.bb
diff options
context:
space:
mode:
authorLei Yang <lei.yang@windriver.com>2013-01-07 01:38:24 +0000
committerJoe MacDonald <joe.macdonald@windriver.com>2013-01-07 15:20:37 -0500
commit7bbb2e57c3c0e170844d24b69b2986c278977a16 (patch)
tree7b49d50c5c70281bea326ed923350aaff63656d0 /meta-networking/recipes-support/netcat/netcat_0.7.1.bb
parenta0292fc5fc84ac016392706de0a531e3ca2b03ea (diff)
downloadmeta-openembedded-contrib-7bbb2e57c3c0e170844d24b69b2986c278977a16.tar.gz
Add netcat-bsd into meta-networking for meta-virutalization libvirt virt-test
The netcat-openbsd in meta-virtualization layer has bugs. This update version will fix "nc: Protocol no available." error. As bruce point, we want to keep netcat in the meta-networking, which meta-virtualization will depend on,and this patch will let netcat-openbsd with low priority to install Signed-off-by: Lei Yang <lei.yang@windriver.com> Signed-off-by: Joe MacDonald <joe.macdonald@windriver.com>
Diffstat (limited to 'meta-networking/recipes-support/netcat/netcat_0.7.1.bb')
-rw-r--r--meta-networking/recipes-support/netcat/netcat_0.7.1.bb11
1 files changed, 5 insertions, 6 deletions
diff --git a/meta-networking/recipes-support/netcat/netcat_0.7.1.bb b/meta-networking/recipes-support/netcat/netcat_0.7.1.bb
index c5ab85d19b..c4f1f331aa 100644
--- a/meta-networking/recipes-support/netcat/netcat_0.7.1.bb
+++ b/meta-networking/recipes-support/netcat/netcat_0.7.1.bb
@@ -1,21 +1,20 @@
+require netcat.inc
DESCRIPTION = "GNU Netcat"
HOMEPAGE = "http://netcat.sourceforge.net"
-SECTION = "console/network"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
-PR = "r0"
+PR = "r1"
SRC_URI = "${SOURCEFORGE_MIRROR}/netcat/netcat-${PV}.tar.bz2"
SRC_URI[md5sum] = "0a29eff1736ddb5effd0b1ec1f6fe0ef"
SRC_URI[sha256sum] = "b55af0bbdf5acc02d1eb6ab18da2acd77a400bafd074489003f3df09676332bb"
-inherit autotools update-alternatives gettext
+inherit autotools
do_install_append() {
- mv ${D}${bindir}/nc ${D}${bindir}/nc.${PN}
+ install -d ${D}${bindir}
+ mv ${D}${bindir}/nc ${D}${bindir}/nc.${PN}
}
-
-ALTERNATIVE_${PN} = "nc"
ALTERNATIVE_PRIORITY = "100"