aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/memcached/memcached_1.6.9.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-06-04 12:07:22 -0700
committerKhem Raj <raj.khem@gmail.com>2021-06-05 06:06:27 -0700
commit4bcefa8176cb832a20f17c548a3108e7e57d6cf0 (patch)
treeb36e76d296ee41d9ef3dfbe04762a676f099d165 /meta-networking/recipes-support/memcached/memcached_1.6.9.bb
parenteada1065ae51a0f47dcbe50714972cf6c6efa8ad (diff)
downloadmeta-openembedded-contrib-4bcefa8176cb832a20f17c548a3108e7e57d6cf0.tar.gz
memcached: upgrade to 1.6.9
Fix Set but unused clang warning sigignore issue is already fixed in 1.6.9 Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support/memcached/memcached_1.6.9.bb')
-rw-r--r--meta-networking/recipes-support/memcached/memcached_1.6.9.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/memcached/memcached_1.6.9.bb b/meta-networking/recipes-support/memcached/memcached_1.6.9.bb
new file mode 100644
index 0000000000..73e18a4038
--- /dev/null
+++ b/meta-networking/recipes-support/memcached/memcached_1.6.9.bb
@@ -0,0 +1,52 @@
+SUMMARY = "A high-performance memory object caching system"
+DESCRIPTION = "\
+ memcached optimizes specific high-load serving applications that are designed \
+ to take advantage of its versatile no-locking memory access system. Clients \
+ are available in several different programming languages, to suit the needs \
+ of the specific application. Traditionally this has been used in mod_perl \
+ apps to avoid storing large chunks of data in Apache memory, and to share \
+ this burden across several machines."
+SECTION = "web"
+HOMEPAGE = "http://memcached.org/"
+LICENSE = "BSD-3-Clause"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=7e5ded7363d335e1bb18013ca08046ff"
+
+inherit autotools
+
+DEPENDS += "libevent"
+RDEPENDS_${PN} += "perl perl-module-posix perl-module-autoloader \
+ perl-module-tie-hash bash \
+ "
+
+SRC_URI = "http://www.memcached.org/files/${BP}.tar.gz \
+ file://memcached-add-hugetlbfs-check.patch \
+ file://0002-stats_prefix.c-Check-for-NDEBUG-before-using-total_w.patch \
+ "
+SRC_URI[sha256sum] = "d5a62ce377314dbffdb37c4467e7763e3abae376a16171e613cbe69956f092d1"
+
+# set the same COMPATIBLE_HOST as libhugetlbfs
+COMPATIBLE_HOST = "(i.86|x86_64|powerpc|powerpc64|aarch64|arm).*-linux*"
+
+python __anonymous () {
+ endianness = d.getVar('SITEINFO_ENDIANNESS')
+ if endianness == 'le':
+ d.appendVar('EXTRA_OECONF', " ac_cv_c_endian=little")
+ else:
+ d.appendVar('EXTRA_OECONF', " ac_cv_c_endian=big")
+}
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[hugetlbfs] = "--enable-hugetlbfs, --disable-hugetlbfs, libhugetlbfs"
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "memcached"
+INITSCRIPT_PARAMS = "defaults"
+
+do_install_append() {
+ install -D -m 755 ${S}/scripts/memcached-init ${D}${sysconfdir}/init.d/memcached
+ mkdir -p ${D}/usr/share/memcached/scripts
+ install -m 755 ${S}/scripts/memcached-tool ${D}/usr/share/memcached/scripts
+ install -m 755 ${S}/scripts/start-memcached ${D}/usr/share/memcached/scripts
+}