aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/ipvsadm/ipvsadm_1.26.bb
diff options
context:
space:
mode:
authorJianchuan Wang <jianchuan.wang@windriver.com>2015-01-22 17:35:56 +0800
committerJoe MacDonald <joe_macdonald@mentor.com>2015-04-15 08:47:26 -0400
commit71cf57715f3e847fad339adcfdaeab511d42d2f7 (patch)
tree1e3310fe82cbffe1b4627a5b59f5a42aeaf95a0d /meta-networking/recipes-support/ipvsadm/ipvsadm_1.26.bb
parentf640eca1cc7919e3f42c9c5790de1d11e982b5f7 (diff)
downloadmeta-openembedded-contrib-71cf57715f3e847fad339adcfdaeab511d42d2f7.tar.gz
ipvsadm: Add version 1.26 (initial recipe)
* add ipvs administration tool Signed-off-by: Jianchuan Wang <jianchuan.wang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support/ipvsadm/ipvsadm_1.26.bb')
-rw-r--r--meta-networking/recipes-support/ipvsadm/ipvsadm_1.26.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/ipvsadm/ipvsadm_1.26.bb b/meta-networking/recipes-support/ipvsadm/ipvsadm_1.26.bb
new file mode 100644
index 0000000000..b640a5081d
--- /dev/null
+++ b/meta-networking/recipes-support/ipvsadm/ipvsadm_1.26.bb
@@ -0,0 +1,35 @@
+SUMMARY = "Linux Virtual Server administration Utility"
+DESCRIPTION = "Ipvsadm is used to set up, maintain or inspect the virtual server \
+table in the Linux kernel. The Linux Virtual Server can be used to \
+build scalable network services based on a cluster of two or more nodes. \
+The active node of the cluster redirects service requests to a \
+collection of server hosts that will actually perform the services. \
+Supported features include two protocols (TCP and UDP), three packet-forwarding \
+methods (NAT, tunneling, and direct routing), and eight load balancing algorithms \
+(round robin, weighted round robin, least-connec-tion, weighted least-connection, \
+locality-based least-connection, locality-based least-connection with replication, \
+destination-hashing, and source-hashing)."
+SECTION = "console/network"
+LICENSE = "GPL-2.0"
+LIC_FILES_CHKSUM = "file://README;beginline=40;endline=56;md5=a54cba37b64924aa5008881607942892"
+
+DEPENDS += "libnl popt"
+
+SRC_URI = "http://www.linuxvirtualserver.org/software/kernel-2.6/${BP}.tar.gz \
+ file://0001-Modify-the-Makefile-for-cross-compile.patch \
+ file://0002-Replace-nl_handle-to-nl_sock.patch \
+ file://0003-ipvsadm-remove-dependency-on-bash.patch \
+"
+
+SRC_URI[md5sum] = "eac3ba3f62cd4dea2da353aeddd353a8"
+SRC_URI[sha256sum] = "6d6c46fecb1c532a892616b4445c73b71730e8790d5630f60269fd9cbee0eb2d"
+
+do_compile() {
+ oe_runmake \
+ CC="${CC} -I${STAGING_INCDIR} -I${STAGING_INCDIR}/libnl3 -L${STAGING_LIBDIR}" \
+ all
+}
+
+do_install() {
+ oe_runmake 'BUILD_ROOT=${D}' install
+}