aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/ipvsadm/ipvsadm
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2016-08-19 18:04:16 +0800
committerJoe MacDonald <joe_macdonald@mentor.com>2016-09-05 13:34:11 -0400
commit1157490a50f896203e9ddc11633943089c7b80ad (patch)
tree0d78263c4000778cd4c77bbae38d589f0ae88050 /meta-networking/recipes-support/ipvsadm/ipvsadm
parent490d792737a9ed00cab3d9e33d4843746150b14b (diff)
downloadmeta-openembedded-contrib-1157490a50f896203e9ddc11633943089c7b80ad.tar.gz
ipvsadm: fix QA warning for GNU_HASH
Add LDFLAGS variable to Makefile so that extra linker flags can be sent via this variable. Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support/ipvsadm/ipvsadm')
-rw-r--r--meta-networking/recipes-support/ipvsadm/ipvsadm/makefile-add-ldflags.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/ipvsadm/ipvsadm/makefile-add-ldflags.patch b/meta-networking/recipes-support/ipvsadm/ipvsadm/makefile-add-ldflags.patch
new file mode 100644
index 0000000000..1bf1eed4c3
--- /dev/null
+++ b/meta-networking/recipes-support/ipvsadm/ipvsadm/makefile-add-ldflags.patch
@@ -0,0 +1,19 @@
+Add LDFLAGS variable to Makefile, make sure the extra linker flags can be passed.
+
+Upstream-Status: Pending
+
+Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
+
+diff --git a/Makefile b/Makefile
+index 461c021..8bc9cde 100644
+--- a/Makefile
++++ b/Makefile
+@@ -86,7 +86,7 @@ libs:
+ make -C libipvs
+
+ ipvsadm: $(OBJS) libs
+- $(CC) $(CFLAGS) -o $@ $(OBJS) $(STATIC_LIBS) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(OBJS) $(STATIC_LIBS) $(LIBS)
+
+ install: all
+ if [ ! -d $(SBIN) ]; then $(MKDIR) -p $(SBIN); fi